summaryrefslogtreecommitdiff
path: root/dev-python/meteo-qt/meteo-qt-0.9.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-03-12 23:25:46 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-03-12 23:25:46 +0000
commitf5be84651ecc167ba6124a7f9bb29842d3cf965a (patch)
treed80f0c1e476232e8e78c4c95873c7547f9beb389 /dev-python/meteo-qt/meteo-qt-0.9.5.ebuild
parent8d63874ab32a64d1c2aa6a64a11971d6a28f270d (diff)
add meteo-qt
Diffstat (limited to 'dev-python/meteo-qt/meteo-qt-0.9.5.ebuild')
-rw-r--r--dev-python/meteo-qt/meteo-qt-0.9.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/meteo-qt/meteo-qt-0.9.5.ebuild b/dev-python/meteo-qt/meteo-qt-0.9.5.ebuild
new file mode 100644
index 00000000..7a15c221
--- /dev/null
+++ b/dev-python/meteo-qt/meteo-qt-0.9.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="System tray application for weather status information"
+HOMEPAGE="https://github.com/dglent/meteo-qt"
+SRC_URI="https://github.com/dglent/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/sip[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+PATCHES="${FILESDIR}/lrelease.patch"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}