summaryrefslogtreecommitdiff
path: root/dev-python/pyvlc/pyvlc-1.0.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
commit7224c1253228e5c29c78cb3f0f26ce34770f2356 (patch)
tree1684924656132935256e034f35f92abee6623265 /dev-python/pyvlc/pyvlc-1.0.ebuild
Added ebuilds for kogaion desktop
Diffstat (limited to 'dev-python/pyvlc/pyvlc-1.0.ebuild')
-rw-r--r--dev-python/pyvlc/pyvlc-1.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pyvlc/pyvlc-1.0.ebuild b/dev-python/pyvlc/pyvlc-1.0.ebuild
new file mode 100644
index 00000000..472927cc
--- /dev/null
+++ b/dev-python/pyvlc/pyvlc-1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit git-2
+
+DESCRIPTION="Python binding to VLC library"
+HOMEPAGE="http://wiki.videolan.org/Python_bindings"
+EGIT_REPO_URI="git://git.videolan.org/vlc/bindings/python.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="generated examples wxwidgets qt4 gtk"
+
+DEPEND="media-video/vlc"
+RDEPEND="${DEPEND}
+ examples? ( dev-python/pygtk )"
+DOCS="README"
+
+S="${WORKDIR}"/${PN}-${PV}
+
+src_compile() {
+ cd "${EGIT_STORE_DIR}"
+ cd "${S}"
+}
+
+src_install() {
+ cd "${S}"
+
+ if use examples ; then
+ cd "${S}"/examples
+ ls -la
+ if use wxwidgets ; then
+ dodoc wxvlc.py
+ fi
+ if use qt4 ; then
+ dodoc qtvlc.py
+ fi
+ if use gtk ; then
+ dodoc gtkvlc.py
+ fi
+ fi
+ if use generated ; then
+ insinto "${S}"/generated
+ dodoc vlc.py
+ fi
+}