summaryrefslogtreecommitdiff
path: root/dev-python/sh/sh-1.12.14-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:43:06 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:43:06 +0000
commit2f545507d69121e1babaf17d18adf242d7e7873a (patch)
tree2c81e4a39e4410662f27e1ce5c4536937957c285 /dev-python/sh/sh-1.12.14-r1.ebuild
parentd4d2bf150ea2694ee559301c60435f4bcde3b3d7 (diff)
PYTHON_COMPAT : 3.5
Diffstat (limited to 'dev-python/sh/sh-1.12.14-r1.ebuild')
-rw-r--r--dev-python/sh/sh-1.12.14-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/sh/sh-1.12.14-r1.ebuild b/dev-python/sh/sh-1.12.14-r1.ebuild
new file mode 100644
index 00000000..a986554d
--- /dev/null
+++ b/dev-python/sh/sh-1.12.14-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python process launching"
+HOMEPAGE="https://amoffat.github.com/sh"
+SRC_URI="https://github.com/amoffat/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}