summaryrefslogtreecommitdiff
path: root/dev-python/sh/sh-1.12.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-07-27 20:21:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-07-27 20:21:00 +0100
commit6378fb0683ac8b6531ce18891147af8fc16d2a59 (patch)
tree20c00b62713f23e10445f3cbb5a6ebaaa8541135 /dev-python/sh/sh-1.12.14.ebuild
parent67d84adae0a92f3fa867f70a60b3d63760ef8623 (diff)
dev-python/sh : new package
Diffstat (limited to 'dev-python/sh/sh-1.12.14.ebuild')
-rw-r--r--dev-python/sh/sh-1.12.14.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/sh/sh-1.12.14.ebuild b/dev-python/sh/sh-1.12.14.ebuild
new file mode 100644
index 00000000..f8b65ab4
--- /dev/null
+++ b/dev-python/sh/sh-1.12.14.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python process launching"
+HOMEPAGE="https://amoffat.github.com/sh"
+SRC_URI="https://github.com/amoffat/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}