summaryrefslogtreecommitdiff
path: root/dev-python/wget/wget-2.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 12:27:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 12:27:09 +0100
commita184a560c1a15c1f4b63c1f4e459cad53ee1c040 (patch)
tree0065aaeddeea2939a861dc1c3441df292826c312 /dev-python/wget/wget-2.2-r1.ebuild
parent6e4ddbd6cb3497bc19a1ed07c8df9f6df1dc79c5 (diff)
dev-python/wget : revision bump, add python3.7 COMPAT
Diffstat (limited to 'dev-python/wget/wget-2.2-r1.ebuild')
-rw-r--r--dev-python/wget/wget-2.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/wget/wget-2.2-r1.ebuild b/dev-python/wget/wget-2.2-r1.ebuild
new file mode 100644
index 00000000..7590d4fd
--- /dev/null
+++ b/dev-python/wget/wget-2.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Python library for downloading from http URLs"
+HOMEPAGE="https://github.com/steveeJ/python-wget"
+
+EGIT_REPO_URI="https://github.com/steveeJ/python-wget.git"
+EGIT_BRANCH="master"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}