summaryrefslogtreecommitdiff
path: root/dev-python/wget/wget-2.2-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-23 13:35:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-23 13:35:38 +0100
commit144df18653faa0735e06b70d096dde84615c070d (patch)
treee9604fd1d0c954f3b73a6a0968884ac520415ae8 /dev-python/wget/wget-2.2-r4.ebuild
parentc8d28427396ca2780a48aa4d5c63c85874171c2e (diff)
dev-python/{sh,typer,wget} : update PYTHON_COMPAT
Diffstat (limited to 'dev-python/wget/wget-2.2-r4.ebuild')
-rw-r--r--dev-python/wget/wget-2.2-r4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/wget/wget-2.2-r4.ebuild b/dev-python/wget/wget-2.2-r4.ebuild
new file mode 100644
index 00000000..e3e09771
--- /dev/null
+++ b/dev-python/wget/wget-2.2-r4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_10,3_11,3_12} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Python library for downloading from http URLs"
+HOMEPAGE="https://github.com/steveeJ/python-wget"
+
+EGIT_REPO_URI="https://github.com/steveeJ/python-wget.git"
+EGIT_BRANCH="master"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="amd64 arm64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}