summaryrefslogtreecommitdiff
path: root/dev-util/molecule/molecule-0.9.24.7.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-10-27 18:38:05 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-10-27 18:38:05 +0200
commit24934e623441310f644e5f72855b0f2bf9f3cd1a (patch)
treea453939bf58199bc2c3ff27bcf0accf2b221c6c4 /dev-util/molecule/molecule-0.9.24.7.ebuild
parent687f45092b4f4ccf33765cee7427f054bae22344 (diff)
Incoming! Moving Rogento.git to kogaion-desktop. Finally
Diffstat (limited to 'dev-util/molecule/molecule-0.9.24.7.ebuild')
-rw-r--r--dev-util/molecule/molecule-0.9.24.7.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/molecule/molecule-0.9.24.7.ebuild b/dev-util/molecule/molecule-0.9.24.7.ebuild
new file mode 100644
index 00000000..20cea1e1
--- /dev/null
+++ b/dev-util/molecule/molecule-0.9.24.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/molecule-0.9.24.6.ebuild,v 1.1 2012/09/11 14:05:57 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*"
+
+inherit python
+
+DESCRIPTION="Release metatool used for creating Sabayon (and Gentoo) releases"
+HOMEPAGE="http://www.sabayon.org"
+SRC_URI="http://bpr.bluepink.ro/~rogentos/distro/${CATEGORY}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/intltool
+ sys-devel/gettext"
+RDEPEND="net-misc/rsync
+ sys-fs/squashfs-tools
+ sys-process/lsof
+ virtual/cdrtools"
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="/usr/lib" \
+ PREFIX="/usr" SYSCONFDIR="/etc" install \
+ || die "emake install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/molecule"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/molecule"
+}