summaryrefslogtreecommitdiff
path: root/media-tv/sopcast/sopcast-3.2.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-16 19:53:34 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-16 19:53:34 +0100
commitf208afe975715fb3f5aa422e3d69f1b5d8a716f3 (patch)
treeb9e4656bb7211ea64bfe310256ae95f94bc70e05 /media-tv/sopcast/sopcast-3.2.6-r1.ebuild
parentf0962ddd7051df1b733d2e2278a5fcf39e467eb7 (diff)
Revert "media-tv/{tv-maxe,sopcast} : sorry lads, but your codebase is way to old to keep things sane anymore, drop"
This reverts commit 8b21ffab3433955fd17c7e6a43d488864f9a951b.
Diffstat (limited to 'media-tv/sopcast/sopcast-3.2.6-r1.ebuild')
-rw-r--r--media-tv/sopcast/sopcast-3.2.6-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-tv/sopcast/sopcast-3.2.6-r1.ebuild b/media-tv/sopcast/sopcast-3.2.6-r1.ebuild
new file mode 100644
index 00000000..ce86a0c5
--- /dev/null
+++ b/media-tv/sopcast/sopcast-3.2.6-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+MY_P="sp-sc-auth"
+MY_PN="sp-auth"
+
+DESCRIPTION="SopCast free P2P Internet TV binary"
+LICENSE="SopCast-unknown-license"
+HOMEPAGE="http://www.sopcast.com/"
+SRC_URI="http://sopcast-player.googlecode.com/files/${MY_PN}-${PV}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+# All dependencies might not be listed, since the binary blob's homepage only lists libstdc++
+RDEPEND="amd64? ( sys-libs/libstdc++-v3[multilib] )
+ x86? ( >=virtual/libstdc++-3.3 )"
+
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_PN}
+
+src_install() {
+ exeinto /usr/bin/
+ newexe sp-sc-auth ${MY_P} || die "newexe failed"
+ dodoc Readme || die "dodoc failed"
+}