summaryrefslogtreecommitdiff
path: root/net-im/telegram-cli/telegram-cli-9999.ebuild
diff options
context:
space:
mode:
authorStefan Cristian B. <steven.darklight@gmail.com>2015-06-18 18:31:03 +0300
committerStefan Cristian B. <steven.darklight@gmail.com>2015-06-18 18:31:03 +0300
commit71c20430bd06d80b663fb54d1df67598d804c219 (patch)
tree8ed9e8852b128c270f9197edf597532ac3fd8e11 /net-im/telegram-cli/telegram-cli-9999.ebuild
parent35875647a1f4db65a3a7a559479ef8e311acbac2 (diff)
parent975d01bc65f0f9190808c0d3cddf3131a790a8f6 (diff)
Merge pull request #52 from crismblog/master
Applications useful and beautiful themes
Diffstat (limited to 'net-im/telegram-cli/telegram-cli-9999.ebuild')
-rw-r--r--net-im/telegram-cli/telegram-cli-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-im/telegram-cli/telegram-cli-9999.ebuild b/net-im/telegram-cli/telegram-cli-9999.ebuild
new file mode 100644
index 00000000..bd4917a8
--- /dev/null
+++ b/net-im/telegram-cli/telegram-cli-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+EGIT_REPO_URI="https://github.com/vysheng/tg.git"
+inherit git-2
+IUSE="lua"
+DESCRIPTION="Command line interface client for Telegram"
+HOMEPAGE="https://github.com/vysheng/tg"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="sys-libs/zlib
+ sys-libs/readline
+ dev-libs/libconfig
+ dev-libs/openssl
+ lua? ( dev-lang/lua )"
+
+src_configure() {
+ econf $(use_enable lua liblua ) --with-progname=telegram-cli
+}
+
+src_install() {
+ newbin telegram telegram-cli
+
+ insinto /etc/telegram-cli/
+ newins tg.pub server.pub
+}