summaryrefslogtreecommitdiff
path: root/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-4.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2015-05-27 22:52:01 +0300
committerBlackNoxis <steven.darklight@gmail.com>2015-05-27 22:52:01 +0300
commitaaa709cb66a7200c9ee988592bb1b793f30af97f (patch)
tree8d7f91eaa9dc71a399e2d67b3f31ff6dfeb80b0a /sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-4.ebuild
parentde0b265971e150ce2a0d78eee7c0750c7eadb327 (diff)
parent73d18d460dc6ae03d75ae9628db3b32a913d270c (diff)
Merge branch 'master' of github.com:Rogentos/kogaion-desktop
Diffstat (limited to 'sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-4.ebuild')
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-4.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-4.ebuild
new file mode 100644
index 00000000..d02b525f
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools-utils systemd
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://bitbucket.org/mgorny/gentoo-systemd-integration"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207
+ !sys-fs/eudev
+ !sys-fs/udev"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-pure-systemd.patch"
+}
+
+src_configure() {
+ local myeconfargs=(
+ "$(systemd_with_unitdir)"
+ # TODO: solve it better in the eclass
+ --with-systemdsystemgeneratordir="$(systemd_get_utildir)"/system-generators
+ )
+
+ autotools-utils_src_configure
+}