summaryrefslogtreecommitdiff
path: root/sys-boot/etcher/etcher-1.3.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-24 19:10:12 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-24 19:10:12 +0000
commit920f63a38ea6f05b63550767e63641792677e149 (patch)
treebd0f00d2a952228666c0c058744fdc289ad9527a /sys-boot/etcher/etcher-1.3.1-r1.ebuild
parentcbeb3b4cc14a0da31d4b985d19fd5d2a65dba670 (diff)
sys-boot/etcher : revision bump (https://gitlab.com/bionel/bionel-icons/commit/c55a599e8537b702d9fb6be171317542f90b74df)
Diffstat (limited to 'sys-boot/etcher/etcher-1.3.1-r1.ebuild')
-rw-r--r--sys-boot/etcher/etcher-1.3.1-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-boot/etcher/etcher-1.3.1-r1.ebuild b/sys-boot/etcher/etcher-1.3.1-r1.ebuild
new file mode 100644
index 00000000..f957dd33
--- /dev/null
+++ b/sys-boot/etcher/etcher-1.3.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils unpacker
+
+DESCRIPTION="Flash OS images to SD cards & USB drives, safely and easily."
+HOMEPAGE="https://etcher.io/"
+SRC_URI="https://github.com/resin-io/${PN}/releases/download/v${PV}/${PN}-electron_${PV}_amd64.deb"
+
+LICENSE="GPL2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/nss
+ gnome-base/gconf
+ media-libs/alsa-lib
+ sys-apps/lsb-release
+ x11-libs/gtk+:2
+ x11-libs/libXtst
+ x11-libs/libnotify"
+RDEPEND="${DEPEND}"
+
+RESTRICT="mirror"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_install() {
+ mv * "${D}" || die
+ sed -i "s/Utility/System/g" "${D}"usr/share/applications/"${PN}"-electron.desktop
+ fperms 0755 /opt/Etcher/"${PN}"-electron || die
+}