summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-10.2.0-r10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-30 23:50:39 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-30 23:50:39 +0000
commit77819fe3944f22678c3bcdf1d773a095441f5140 (patch)
treeddc9dcd1edebe1e94204dfb4bf09ade2c9552f0f /sys-devel/gcc/gcc-10.2.0-r10.ebuild
parent826d1b3f488d3549cbd42ccc73ad90ea1ce88f0b (diff)
toolchain bump
Diffstat (limited to 'sys-devel/gcc/gcc-10.2.0-r10.ebuild')
-rw-r--r--sys-devel/gcc/gcc-10.2.0-r10.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-10.2.0-r10.ebuild b/sys-devel/gcc/gcc-10.2.0-r10.ebuild
new file mode 100644
index 00000000..9bda9722
--- /dev/null
+++ b/sys-devel/gcc/gcc-10.2.0-r10.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PATCH_VER="4"
+
+inherit toolchain
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND=""
+BDEPEND="${CATEGORY}/binutils"
+
+src_prepare() {
+ has_version '>=sys-libs/glibc-2.32-r1' && rm -v "${WORKDIR}/patch/23_all_disable-riscv32-ABIs.patch"
+ toolchain_src_prepare
+}