summaryrefslogtreecommitdiff
path: root/sys-libs/kpmcore/kpmcore-3.2.1-r10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-30 12:20:44 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-30 12:20:44 +0100
commit1304264d6db97d622783a1a3d6c9933e029e1dae (patch)
tree512ab2680ded6dd9cc21ecccd66c20b8da7edc20 /sys-libs/kpmcore/kpmcore-3.2.1-r10.ebuild
parent1ca20f8af778c6f7b860fc093f779d63804e83a2 (diff)
parentb68bd360ef1c8817650e105f9c8187b82e428765 (diff)
Merge branch 'edge' into next
Diffstat (limited to 'sys-libs/kpmcore/kpmcore-3.2.1-r10.ebuild')
-rw-r--r--sys-libs/kpmcore/kpmcore-3.2.1-r10.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-libs/kpmcore/kpmcore-3.2.1-r10.ebuild b/sys-libs/kpmcore/kpmcore-3.2.1-r10.ebuild
new file mode 100644
index 00000000..a4fb03c9
--- /dev/null
+++ b/sys-libs/kpmcore/kpmcore-3.2.1-r10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit ecm kde.org
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="amd64 ~arm x86"
+fi
+
+DESCRIPTION="Library for managing partitions"
+HOMEPAGE="https://www.kde.org/applications/system/kdepartitionmanager"
+LICENSE="GPL-3"
+SLOT="5/6"
+IUSE=""
+
+RDEPEND="
+ kde-frameworks/kcoreaddons
+ kde-frameworks/ki18n
+ kde-frameworks/kservice
+ kde-frameworks/kwidgetsaddons
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-libs/libatasmart
+ >=sys-apps/util-linux-2.30
+ >=sys-block/parted-3
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"