summaryrefslogtreecommitdiff
path: root/www-plugins/freshplayerplugin/freshplayerplugin-0.3.0.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2015-06-24 10:49:54 +0300
committerBlackNoxis <steven.darklight@gmail.com>2015-06-24 10:49:54 +0300
commit66c035f64fef20199fad12fb75285aec3ffe8b33 (patch)
tree52417e0600a3c1885b2e8cd163d6d5b1368c964a /www-plugins/freshplayerplugin/freshplayerplugin-0.3.0.ebuild
parent3f3eb088770626f5798e801e40404e6336f8628e (diff)
parentdc902eb88e6dfa3cc46a065a8a5fc8c708c94915 (diff)
Merge branch 'master' of github.com:Rogentos/kogaion-desktop
Diffstat (limited to 'www-plugins/freshplayerplugin/freshplayerplugin-0.3.0.ebuild')
-rw-r--r--www-plugins/freshplayerplugin/freshplayerplugin-0.3.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/www-plugins/freshplayerplugin/freshplayerplugin-0.3.0.ebuild b/www-plugins/freshplayerplugin/freshplayerplugin-0.3.0.ebuild
new file mode 100644
index 00000000..1c650fe8
--- /dev/null
+++ b/www-plugins/freshplayerplugin/freshplayerplugin-0.3.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils cmake-multilib nsplugins
+
+DESCRIPTION="ppapi2npapi compatibility layer"
+HOMEPAGE="https://github.com/i-rinat/freshplayerplugin"
+SRC_URI="https://github.com/i-rinat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-util/ragel
+ dev-libs/libconfig
+ media-libs/freetype:2
+ >=dev-libs/glib-2.38.2-r1:2
+ >=dev-util/cmake-2.8.8
+ >=media-libs/alsa-lib-1.0.28
+ >=x11-libs/pango-1.36.5
+ >=x11-libs/gtk+-2.20:2
+ >=media-libs/mesa-10.0.4
+ >=dev-libs/libevent-2.0.21-r1
+ "
+RDEPEND="
+ www-plugins/chrome-binary-plugins"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+multilib_src_configure() {
+ local mycmakeargs="-DFRESHPLAYERPLUGINPATH=${EPREFIX}/usr/$(get_libdir)/freshplayerplugin"
+
+ cmake-utils_src_configure
+}
+
+multilib_src_install() {
+ # install the wrapper
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe libfreshwrapper-pepperflash.so
+ # install wrapper configuration file
+ cd "${S}"
+ dodir /usr/share/${PN} || die
+ insinto /usr/share/${PN} || die
+ doins -r "${S}"/data/freshwrapper.conf.example || die
+ dosym /usr/share/${PN}/freshwrapper.conf.example /etc/freshwrapper.conf || die
+}