summaryrefslogtreecommitdiff
path: root/x11-themes/numix-icon-theme/numix-icon-theme-1.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:35:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:35:49 +0000
commita5b0e82615a45715903e6f6462326a1ca36efb59 (patch)
tree83e96ce4cb638efc146a027e391ab5e1fcb90898 /x11-themes/numix-icon-theme/numix-icon-theme-1.0-r3.ebuild
parent8a71dc5ba2884b0b61a5df0cfdaa37eb2d3cc74a (diff)
x11-themes/numix-icon-theme : drop x11-themes/gnome-icon-theme dependency (masked in gentoo)
Diffstat (limited to 'x11-themes/numix-icon-theme/numix-icon-theme-1.0-r3.ebuild')
-rw-r--r--x11-themes/numix-icon-theme/numix-icon-theme-1.0-r3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-themes/numix-icon-theme/numix-icon-theme-1.0-r3.ebuild b/x11-themes/numix-icon-theme/numix-icon-theme-1.0-r3.ebuild
new file mode 100644
index 00000000..a0666078
--- /dev/null
+++ b/x11-themes/numix-icon-theme/numix-icon-theme-1.0-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit gnome2-utils
+
+DESCRIPTION="Icon theme from the numix project."
+HOMEPAGE="http://numixproject.org/"
+SRC_URI="http://mirror.math.princeton.edu/pub/redcorelinux/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-3.0+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="x11-themes/hicolor-icon-theme"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/"${P}"
+
+src_install() {
+ insinto /usr/share/icons
+ doins -r Numix-Light
+ doins -r Numix
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}