summaryrefslogtreecommitdiff
path: root/app-editors/notepadqq/notepadqq-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/notepadqq/notepadqq-1.2.0.ebuild')
-rw-r--r--app-editors/notepadqq/notepadqq-1.2.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-editors/notepadqq/notepadqq-1.2.0.ebuild b/app-editors/notepadqq/notepadqq-1.2.0.ebuild
new file mode 100644
index 00000000..d724ed8a
--- /dev/null
+++ b/app-editors/notepadqq/notepadqq-1.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /dev-util/notepadqq-9999.ebuild,v 0.1 frostwork $
+
+EAPI=5
+inherit eutils qmake-utils git-r3
+
+DESCRIPTION="Notepad++-like editor for Linux"
+EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+EGIT_COMMIT="ab074d30e02d49e0fe6957c1523e7fed239aff7d"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtscript:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtsvg:5
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr" ${PN}.pro
+}
+
+src_install() {
+ make INSTALL_ROOT=${D} install || die
+}