summaryrefslogtreecommitdiff
path: root/app-misc/kogaion-version/kogaion-version-2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/kogaion-version/kogaion-version-2.ebuild')
-rw-r--r--app-misc/kogaion-version/kogaion-version-2.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/app-misc/kogaion-version/kogaion-version-2.ebuild b/app-misc/kogaion-version/kogaion-version-2.ebuild
new file mode 100644
index 00000000..0984766d
--- /dev/null
+++ b/app-misc/kogaion-version/kogaion-version-2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 2004-2013 Kogaion
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit multilib
+
+DESCRIPTION="Kogaion system release virtual package"
+HOMEPAGE="http://www.rogentos.ro"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+
+IUSE=""
+DEPEND=""
+GCC_VER="4.8"
+PYTHON_VER="2.7"
+# Listing default packages for the current release
+RDEPEND="!app-admin/eselect-init
+ !sys-apps/hal
+ !sys-auth/consolekit
+ app-eselect/eselect-python
+ sys-apps/gentoo-systemd-integration
+ dev-lang/python:${PYTHON_VER}
+ sys-apps/systemd
+ sys-devel/base-gcc:${GCC_VER}
+ sys-devel/gcc-config"
+
+src_unpack () {
+ echo "Kogaion Linux ${ARCH} ${PV}" > "${T}/kogaion-release"
+
+ # Anaconda expects a "release" somewhere in the string
+ # and no trailing \n
+ echo -n "Kogaion ${ARCH} release ${PV}" > "${T}/system-release"
+ mkdir -p "${S}" || die
+}
+
+src_install () {
+ insinto /etc
+ doins "${T}"/kogaion-release
+ doins "${T}"/system-release
+
+ # Bug 3459 - reduce the risk of fork bombs
+ insinto /etc/security/limits.d
+ doins "${FILESDIR}/00-sabayon-anti-fork-bomb.conf"
+}
+
+pkg_postinst() {
+ # Setup Python ${PYTHON_VER}
+ eselect python set python${PYTHON_VER}
+ # No need to set the GCC profile here, since it's done in base-gcc
+
+ # Improve systemd support
+ if [[ ! -L /etc/mtab ]] && [[ -e /proc/self/mounts ]]; then
+ rm -f /etc/mtab
+ einfo "Migrating /etc/mtab to a /proc/self/mounts symlink"
+ ln -sf /proc/self/mounts /etc/mtab
+ fi
+
+ # force kdm back to the default runlevel if added to boot
+ # this is in preparation for the logind migration
+ local xdm_conf="${ROOT}/etc/conf.d/xdm"
+ local xdm_boot_runlevel="${ROOT}/etc/runlevels/boot/xdm"
+ local xdm_default_runlevel="${ROOT}/etc/runlevels/default/xdm"
+ if [ -e "${xdm_conf}" ] && [ -e "${xdm_boot_runlevel}" ]; then
+ DISPLAYMANAGER=""
+ . "${xdm_conf}"
+ if [ "${DISPLAYMANAGER}" = "kdm" ]; then
+ elog "Moving xdm (kdm) from boot runlevel to default"
+ elog "or logind will not work as expected"
+ mv -f "${xdm_boot_runlevel}" "${xdm_default_runlevel}"
+ fi
+ fi
+
+ # remove old hal udev rules.d file, if found. sys-apps/hal is long gone.
+ rm -f "${ROOT}/lib/udev/rules.d/90-hal.rules"
+
+ # make sure that systemd is correctly linked to /sbin/init
+ # Drop this in 2015, keep in sync with systemd-sysv-utils
+ ln -sf ../usr/lib/systemd/systemd "${ROOT}/sbin/init" || true
+}