summaryrefslogtreecommitdiff
path: root/dev-python/python-exec/python-exec-2.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-exec/python-exec-2.9999.ebuild')
-rw-r--r--dev-python/python-exec/python-exec-2.9999.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/python-exec/python-exec-2.9999.ebuild b/dev-python/python-exec/python-exec-2.9999.ebuild
deleted file mode 100644
index 7a023a0f..00000000
--- a/dev-python/python-exec/python-exec-2.9999.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-2.9999.ebuild,v 1.6 2014/07/06 13:18:50 mgorny Exp $
-
-EAPI=5
-
-#if LIVE
-AUTOTOOLS_AUTORECONF=yes
-EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
-EGIT_BRANCH="python-exec2"
-
-inherit git-r3
-#endif
-
-# Kids, don't do this at home!
-inherit python-utils-r1
-PYTHON_COMPAT=( "${_PYTHON_ALL_IMPLS[@]}" )
-
-inherit autotools-utils python-r1
-
-DESCRIPTION="Python script wrapper"
-HOMEPAGE="https://bitbucket.org/mgorny/python-exec/"
-SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
-
-LICENSE="BSD-2"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND="!<dev-python/python-exec-10000"
-
-#if LIVE
-KEYWORDS=
-SRC_URI=
-#endif
-
-src_configure() {
- local pyimpls i EPYTHON
- for i in "${PYTHON_COMPAT[@]}"; do
- python_export "${i}" EPYTHON
- pyimpls+=" ${EPYTHON}"
- done
-
- local myeconfargs=(
- --with-eprefix="${EPREFIX}"
- --with-python-impls="${pyimpls}"
- )
-
- autotools-utils_src_configure
-}