summaryrefslogtreecommitdiff
path: root/gnome-base/libgnome/libgnome-2.32.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/libgnome/libgnome-2.32.0.ebuild')
-rw-r--r--gnome-base/libgnome/libgnome-2.32.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnome-base/libgnome/libgnome-2.32.0.ebuild b/gnome-base/libgnome/libgnome-2.32.0.ebuild
new file mode 100644
index 00000000..a207f4e0
--- /dev/null
+++ b/gnome-base/libgnome/libgnome-2.32.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnome/libgnome-2.32.0.ebuild,v 1.2 2010/10/21 21:33:15 eva Exp $
+
+EAPI="3"
+GCONF_DEBUG="yes"
+
+inherit gnome2 eutils
+
+DESCRIPTION="Essential Gnome Libraries"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="doc esd"
+
+SRC_URI="${SRC_URI}"
+
+RDEPEND=">=gnome-base/gconf-2
+ >=dev-libs/glib-2.16
+ >=gnome-base/gnome-vfs-2.5.3
+ >=gnome-base/libbonobo-2.13
+ >=dev-libs/popt-1.7
+ media-libs/libcanberra
+ esd? (
+ >=media-sound/esound-0.2.26
+ >=media-libs/audiofile-0.2.3 )"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.17
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+PDEPEND="gnome-base/gvfs"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-schemas-install
+ --enable-sound
+ $(use_enable esd)"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Make sure menus have icons. People don't like change
+ epatch "${FILESDIR}/${PN}-2.28.0-menus-have-icons.patch"
+
+ # Sabayon customization
+ epatch "${FILESDIR}/${PN}-2.32-sabayon-background.patch"
+}
+