summaryrefslogtreecommitdiff
path: root/lxqt-base/liblxqt/liblxqt-0.12.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/liblxqt/liblxqt-0.12.0-r2.ebuild')
-rw-r--r--lxqt-base/liblxqt/liblxqt-0.12.0-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/lxqt-base/liblxqt/liblxqt-0.12.0-r2.ebuild b/lxqt-base/liblxqt/liblxqt-0.12.0-r2.ebuild
new file mode 100644
index 00000000..7079991a
--- /dev/null
+++ b/lxqt-base/liblxqt/liblxqt-0.12.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="Common base library for the LXQt desktop environment"
+HOMEPAGE="http://lxqt.org/"
+
+SRC_URI="https://github.com/lxde/${PN}/releases/download/${PV}/${P}.tar.xz"
+KEYWORDS="amd64"
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+RDEPEND=">=dev-libs/libqtxdg-3.1.0
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5[X]
+ >=lxqt-base/lxqt-build-tools-0.4.0
+ x11-libs/libXScrnSaver"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ tc-is-gcc && [[ $(gcc-version) < 4.8 ]] && \
+ die 'The active compiler needs to be gcc 4.8 (or newer)'
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=( -DPULL_TRANSLATIONS=OFF )
+ cmake-utils_src_configure
+}