summaryrefslogtreecommitdiff
path: root/mate-extra/mate-indicator-applet/mate-indicator-applet-1.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'mate-extra/mate-indicator-applet/mate-indicator-applet-1.8.0.ebuild')
-rw-r--r--mate-extra/mate-indicator-applet/mate-indicator-applet-1.8.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/mate-extra/mate-indicator-applet/mate-indicator-applet-1.8.0.ebuild b/mate-extra/mate-indicator-applet/mate-indicator-applet-1.8.0.ebuild
new file mode 100644
index 00000000..7f3a14db
--- /dev/null
+++ b/mate-extra/mate-indicator-applet/mate-indicator-applet-1.8.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Indicator Applet for MATE"
+HOMEPAGE="http://mate-desktop.org"
+SRC_URI="http://pub.mate-desktop.org/releases/1.8/${PN}-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ >=mate-base/mate-panel-${PV}"
+DEPEND="
+ >=sys-devel/autoconf-2.53
+ >=sys-devel/automake-1.14.0
+ >=sys-devel/libtool-2.4-r1
+ >=dev-libs/glib-2.38.2-r1
+ >=dev-util/pkgconfig-0.28-r1
+ dev-libs/libindicator-gtk2
+ dev-util/intltool"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+src_configure() {
+ econf \
+ --disable-static
+}
+
+src_compile() {
+ emake || die "compilation failed"
+}
+
+src_install() {
+ default
+}