summaryrefslogtreecommitdiff
path: root/net-fs/samba-config-redcore/samba-config-redcore-1337.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/samba-config-redcore/samba-config-redcore-1337.ebuild')
-rw-r--r--net-fs/samba-config-redcore/samba-config-redcore-1337.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-fs/samba-config-redcore/samba-config-redcore-1337.ebuild b/net-fs/samba-config-redcore/samba-config-redcore-1337.ebuild
new file mode 100644
index 00000000..1b3e2c9d
--- /dev/null
+++ b/net-fs/samba-config-redcore/samba-config-redcore-1337.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils user
+
+DESCRIPTION="Redcore Linux Samba configuration files"
+HOMEPAGE="https://redcorelinux.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S=${FILESDIR}
+
+src_install() {
+ dodir etc/samba
+ insinto etc/samba
+ newins redcore-smb.conf smb.conf
+ dodir var/lib/samba/usershare
+}
+
+pkg_preinst() {
+ enewgroup smbshare
+}
+
+pkg_postinst() {
+ chown root:smbshare /var/lib/samba/usershare
+ chmod 1770 /var/lib/samba/usershare
+}