summaryrefslogtreecommitdiff
path: root/net-im/blight/blight-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/blight/blight-9999.ebuild')
-rw-r--r--net-im/blight/blight-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-im/blight/blight-9999.ebuild b/net-im/blight/blight-9999.ebuild
new file mode 100644
index 00000000..ce4a0b83
--- /dev/null
+++ b/net-im/blight/blight-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit git-2
+
+DESCRIPTION="Cross-platform graphical user interface for Tox written in Racket"
+HOMEPAGE="https://github.com/lehitoskin/blight"
+EGIT_REPO_URI="git://github.com/lehitoskin/blight
+ https://github.com/lehitoskin/blight"
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="net-libs/tox
+ >=dev-db/sqlite-3.8.2
+ >=dev-scheme/racket-6.0.1[X]"
+
+src_prepare() {
+ raco pkg install --no-setup github://github.com/lehitoskin/libtoxcore-racket/master
+ epatch "$FILESDIR/${P}.patch"
+ epatch_user
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}/usr" install
+}