summaryrefslogtreecommitdiff
path: root/net-libs/tox/tox-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/tox/tox-9999.ebuild')
-rw-r--r--net-libs/tox/tox-9999.ebuild41
1 files changed, 12 insertions, 29 deletions
diff --git a/net-libs/tox/tox-9999.ebuild b/net-libs/tox/tox-9999.ebuild
index fc7d1f40..3b440eeb 100644
--- a/net-libs/tox/tox-9999.ebuild
+++ b/net-libs/tox/tox-9999.ebuild
@@ -1,24 +1,23 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=5
-inherit autotools eutils git-2 user systemd
+inherit autotools git-2
-DESCRIPTION="Encrypted P2P, messaging, and audio/video calling platform"
-HOMEPAGE="https://tox.chat"
+DESCRIPTION="Encrypted P2P, messenging, and audio/video calling platform"
+HOMEPAGE="https://tox.im"
SRC_URI=""
-EGIT_REPO_URI="git://github.com/irungentoo/toxcore.git
- https://github.com/irungentoo/toxcore.git"
+EGIT_REPO_URI="https://github.com/irungentoo/toxcore"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="+av daemon log log-debug log-error log-info log-trace log-warn ntox static-libs test"
+IUSE="+av daemon logging log-debug log-error log-info log-warn ntox static-libs test"
RDEPEND="
- >=dev-libs/libsodium-0.6.1[urandom,asm]
+ >=dev-libs/libsodium-1.0.0
daemon? ( dev-libs/libconfig )
av? ( media-libs/libvpx
media-libs/opus )
@@ -31,13 +30,12 @@ pkg_setup() {
unset loglevel
if use log-info || use log-debug || use log-warn || use log-error ; then
- if use !log ; then
+ if use !logging ; then
ewarn "Logging disabled, but log level set,"
ewarn "it will have no effect."
else
- use log-trace && loglevel=" TRACE"
+ use log-info && loglevel=" INFO"
use log-debug && loglevel="${loglevel} DEBUG"
- use log-info && loglevel="${loglevel} INFO"
use log-warn && loglevel="${loglevel} WARNING"
use log-error && loglevel="${loglevel} ERROR"
@@ -58,8 +56,8 @@ src_prepare() {
src_configure() {
econf \
- $(use_enable log) \
- $(usex log "--with-log-level=${loglevel##* }" "") \
+ $(use_enable logging) \
+ $(usex logging "--with-logger-level=${loglevel##* }" "") \
$(use_enable av) \
$(use_enable test tests) \
$(use_enable ntox) \
@@ -70,21 +68,6 @@ src_configure() {
src_install() {
default
use daemon && { newinitd "${FILESDIR}"/initd tox-dht-daemon
- newconfd "${FILESDIR}"/confd tox-dht-daemon
- insinto /etc
- doins "${FILESDIR}"/tox-bootstrapd.conf
- systemd_dounit "${FILESDIR}"/tox-bootstrapd.service ; }
+ newconfd "${FILESDIR}"/confd tox-dht-daemon ; }
prune_libtool_files
}
-
-pkg_postinst() {
- use daemon && { enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
- ewarn "Backwards compatability with the bootstrap daemon"
- ewarn "might have been broken a while ago."
- ewarn "To resolve this issue, REMOVE the following files:"
- ewarn "/var/lib/tox-dht-bootstrap/key"
- ewarn "/etc/tox-bootstrapd.conf"
- ewarn "/run/tox-dht-bootstrap/tox-dht-bootstrap.pid"
- ewarn "Then just re-emerge net-libs/tox" ; }
-}