summaryrefslogtreecommitdiff
path: root/net-misc/modem-manager-gui/modem-manager-gui-0.0.17.1-r1708.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/modem-manager-gui/modem-manager-gui-0.0.17.1-r1708.ebuild')
-rw-r--r--net-misc/modem-manager-gui/modem-manager-gui-0.0.17.1-r1708.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/modem-manager-gui/modem-manager-gui-0.0.17.1-r1708.ebuild b/net-misc/modem-manager-gui/modem-manager-gui-0.0.17.1-r1708.ebuild
new file mode 100644
index 00000000..79c6fbf2
--- /dev/null
+++ b/net-misc/modem-manager-gui/modem-manager-gui-0.0.17.1-r1708.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Frontend for ModemManager daemon able to control specific modem functions"
+HOMEPAGE="http://linuxonly.ru/cms/page.php?"
+SRC_URI="http://download.tuxfamily.org/gsf/source/${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+networkmanager +ofono -connman"
+
+RDEPEND="
+ sys-libs/gdbm
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ net-misc/modemmanager
+ ofono? ( net-misc/ofono )
+ networkmanager? ( net-misc/networkmanager )
+ connman? ( net-misc/connman )"
+DEPEND="
+ app-text/po4a
+ dev-util/itstool
+ "
+
+S="${WORKDIR}/${PN}-${PV}"
+
+src_configure() {
+ econf
+}
+
+src_compile() {
+ emake || die "compilation failed"
+}
+
+src_install() {
+ default
+}