summaryrefslogtreecommitdiff
path: root/net-misc/udpcast/udpcast-20120424.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/udpcast/udpcast-20120424.ebuild')
-rw-r--r--net-misc/udpcast/udpcast-20120424.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/udpcast/udpcast-20120424.ebuild b/net-misc/udpcast/udpcast-20120424.ebuild
new file mode 100644
index 00000000..f4ae0969
--- /dev/null
+++ b/net-misc/udpcast/udpcast-20120424.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/udpcast/udpcast-20120424.ebuild,v 1.1 2012/10/08 12:03:04 jer Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Multicast file transfer tool"
+HOMEPAGE="http://udpcast.linux.lu/"
+SRC_URI="http://udpcast.linux.lu/download/${P}.tar.bz2"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+
+src_prepare() {
+ epatch "${FILESDIR}"/"${PN}"-define.patch
+ sed -i Makefile.in \
+ -e '/^LDFLAGS +=-s/d' \
+ -e '/^CFLAGS/s: -O6::g' \
+ || die
+}
+
+src_install() {
+ default
+ dodoc *.txt
+}