summaryrefslogtreecommitdiff
path: root/sys-boot/plymouth/plymouth-0.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/plymouth/plymouth-0.9.0.ebuild')
-rw-r--r--sys-boot/plymouth/plymouth-0.9.0.ebuild100
1 files changed, 0 insertions, 100 deletions
diff --git a/sys-boot/plymouth/plymouth-0.9.0.ebuild b/sys-boot/plymouth/plymouth-0.9.0.ebuild
deleted file mode 100644
index ec792e37..00000000
--- a/sys-boot/plymouth/plymouth-0.9.0.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-SRC_URI=""
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="git://anongit.freedesktop.org/plymouth"
- AUTOTOOLS_AUTORECONF="1"
- inherit git-r3
-else
- SRC_URI="${SRC_URI} http://www.freedesktop.org/software/plymouth/releases/${P}.tar.bz2"
-fi
-
-inherit autotools-utils readme.gentoo systemd toolchain-funcs
-
-DESCRIPTION="Graphical boot animation (splash) and logger"
-HOMEPAGE="http://cgit.freedesktop.org/plymouth/"
-
-LICENSE="GPL-2"
-SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="debug gdm +gtk +libkms +pango static-libs"
-
-CDEPEND="
- >=media-libs/libpng-1.2.16
- gtk? (
- dev-libs/glib:2
- >=x11-libs/gtk+-2.12:2 )
- libkms? ( x11-libs/libdrm[libkms] )
- pango? ( >=x11-libs/pango-1.21 )
-"
-DEPEND="${CDEPEND}
- virtual/pkgconfig
-"
-# Block due bug #383067
-RDEPEND="${CDEPEND}
- virtual/udev
- >=x11-themes/kogaion-artwork-core-1
- !<sys-kernel/dracut-0.37-r3
-"
-
-DOC_CONTENTS="
- Follow the following instructions to set up Plymouth:\n
- http://dev.gentoo.org/~aidecoe/doc/en/plymouth.xml
-"
-
-src_prepare() {
- # Kogaion: setup our default settings
- epatch "${FILESDIR}/${PN}-kogaion-defaults-2.patch"
-
- epatch_user
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local myeconfargs=(
- --with-system-root-install=no
- --localstatedir=/var
- --without-rhgb-compat-link
- --enable-systemd-integration
- $(use_enable debug tracing)
- $(use_enable gtk gtk)
- $(use_enable libkms drm)
- $(use_enable pango)
- $(use_enable gdm gdm-transition)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
-
- # Kogaion: provided by kogaion-artwork-core
- rm "${D}/usr/share/plymouth/bizcom.png"
-
- # Install compatibility symlinks as some rdeps hardcode the paths
- dosym /usr/bin/plymouth /bin/plymouth
- dosym /usr/sbin/plymouth-set-default-theme /sbin/plymouth-set-default-theme
- dosym /usr/sbin/plymouthd /sbin/plymouthd
-
- readme.gentoo_create_doc
-
- # looks like make install create /var/run/plymouth
- # this is not needed for systemd, same should hold for openrc
- # so remove
- rm -rf "${D}"/var/run
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
- if ! has_version "sys-kernel/dracut" && ! has_version "sys-kernel/genkernel-next[plymouth]"; then
- ewarn "If you want initramfs builder with plymouth support, please emerge"
- ewarn "sys-kernel/dracut or sys-kernel/genkernel-next[plymouth]."
- fi
-}