summaryrefslogtreecommitdiff
path: root/sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r5.ebuild')
-rw-r--r--sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r5.ebuild b/sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r5.ebuild
new file mode 100644
index 00000000..80ffaf22
--- /dev/null
+++ b/sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="Redcore Linux Dracut configuration files"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S="${FILESDIR}"
+
+src_install() {
+ dodir "etc/dracut.conf.d" || die
+ insinto "etc/dracut.conf.d" || die
+ newins redcore-dracut.conf redcore-dracut.conf.example || die
+}
+
+pkg_preinst() {
+ if [[ -f ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf" ]]; then
+ rm -rf ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf"
+ fi
+}
+
+pkg_postinst() {
+ cp -avx ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf.example" ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf"
+}