summaryrefslogtreecommitdiff
path: root/x11-misc/compton-conf/compton-conf-0.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/compton-conf/compton-conf-0.4.0.ebuild')
-rw-r--r--x11-misc/compton-conf/compton-conf-0.4.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/compton-conf/compton-conf-0.4.0.ebuild b/x11-misc/compton-conf/compton-conf-0.4.0.ebuild
new file mode 100644
index 00000000..bbc40dca
--- /dev/null
+++ b/x11-misc/compton-conf/compton-conf-0.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2016-2017 Redcore Linux Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="GUI configuration tool for compton X composite manager"
+HOMEPAGE="https://github.com/lxde/compton-conf"
+SRC_URI="https://github.com/lxde/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep linguist-tools)
+ $(add_qt_dep qtwidgets)
+ >=lxqt-base/lxqt-build-tools-0.5.0"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake-utils_src_install
+ rm -rf "${D}"usr/share/"${PN}"
+}