summaryrefslogtreecommitdiff
path: root/x11-misc/qlipper/qlipper-5.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/qlipper/qlipper-5.1.1.ebuild')
-rw-r--r--x11-misc/qlipper/qlipper-5.1.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/qlipper/qlipper-5.1.1.ebuild b/x11-misc/qlipper/qlipper-5.1.1.ebuild
new file mode 100644
index 00000000..0fa83298
--- /dev/null
+++ b/x11-misc/qlipper/qlipper-5.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Lightweight and cross-platform clipboard history applet"
+HOMEPAGE="https://github.com/pvanek/qlipper"
+SRC_URI="https://github.com/pvanek/qlipper/archive/5.1.1.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+# bundles x11-libs/libqxt but no qt5 system version is available yet
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}