summaryrefslogtreecommitdiff
path: root/x11-themes/moka-icon-theme/moka-icon-theme-5.3.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/moka-icon-theme/moka-icon-theme-5.3.6.ebuild')
-rw-r--r--x11-themes/moka-icon-theme/moka-icon-theme-5.3.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-themes/moka-icon-theme/moka-icon-theme-5.3.6.ebuild b/x11-themes/moka-icon-theme/moka-icon-theme-5.3.6.ebuild
new file mode 100644
index 00000000..318b1efa
--- /dev/null
+++ b/x11-themes/moka-icon-theme/moka-icon-theme-5.3.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+
+inherit eutils autotools
+
+DESCRIPTION="Moka is a stylized Linux desktop icon set, and the titular icon theme of the Moka Project. They are designed to be clear, simple and consistent."
+HOMEPAGE="http://snwh.org"
+if [[ ${PV} == *9999* ]];then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/moka-project/moka-icon-theme.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/moka-project/moka-icon-theme/archive/v${PV}/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+ RESTRICT="mirror"
+fi
+
+LICENSE="LGPL-3.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-themes/faba-icon-theme"
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ eapply_user
+ eautoreconf
+}
+
+src_compile(){
+ emake DESTDIR="${D}" || die
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die
+}