summaryrefslogtreecommitdiff
path: root/app-arch/unp/unp-2.0_pre10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-11 11:34:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-11 11:34:48 +0000
commit70fb964b97d74b88cbbdd3fcbf5871d57323dfd3 (patch)
tree1fe339777089a670d8f34e4cef95a2ef382b8e96 /app-arch/unp/unp-2.0_pre10.ebuild
parente644f875e1d27155e8829b8f7385a8b2d790bcce (diff)
gentoo auto-resync : 11:02:2024 - 11:34:48
Diffstat (limited to 'app-arch/unp/unp-2.0_pre10.ebuild')
-rw-r--r--app-arch/unp/unp-2.0_pre10.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-arch/unp/unp-2.0_pre10.ebuild b/app-arch/unp/unp-2.0_pre10.ebuild
new file mode 100644
index 000000000000..c719be032835
--- /dev/null
+++ b/app-arch/unp/unp-2.0_pre10.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 strip-linguas
+
+DESCRIPTION="Script for unpacking various file formats"
+HOMEPAGE="https://packages.qa.debian.org/u/unp.html"
+MY_PV="${PV/_pre/$'\x7e'pre}"
+SRC_URI="mirror://debian/pool/main/u/unp/${PN}_${MY_PV}.tar.xz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+RDEPEND="${DEPEND}
+ dev-lang/perl"
+
+# tests in upstream tarball are missing sample files
+RESTRICT="test"
+
+src_compile() {
+ if use nls; then
+ strip-linguas -i .
+ if [ -n "$LINGUAS" ]; then
+ emake -C po MOFILES="${LINGUAS// /.po }.po"
+ else
+ emake -C po
+ fi
+ fi
+}
+
+src_install() {
+ dobin unp
+ dosym unp /usr/bin/ucat
+ doman debian/unp.1
+ dodoc debian/changelog debian/README.Debian
+ newbashcomp debian/unp.bash-completion unp
+
+ if use nls; then
+ if [ -n "$LINGUAS" ]; then
+ emake -C po MOFILES="${LINGUAS// /.mo }.mo" DESTDIR="${D}" install
+ else
+ emake -C po DESTDIR="${D}" install
+ fi
+ fi
+}