summaryrefslogtreecommitdiff
path: root/app-editors/bluefish
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-editors/bluefish
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-editors/bluefish')
-rw-r--r--app-editors/bluefish/Manifest3
-rw-r--r--app-editors/bluefish/bluefish-2.2.12-r1.ebuild95
-rw-r--r--app-editors/bluefish/bluefish-2.2.12.ebuild29
3 files changed, 113 insertions, 14 deletions
diff --git a/app-editors/bluefish/Manifest b/app-editors/bluefish/Manifest
index 8cf86d11abde..40ae6b5f4d2a 100644
--- a/app-editors/bluefish/Manifest
+++ b/app-editors/bluefish/Manifest
@@ -1,4 +1,5 @@
AUX bluefish-2.2.9-charmap_configure.patch 728 BLAKE2B fc7231ab28c0d0c4480e48f965d26ee18ae5819e412488ab8a5e30e3cee6925b73daa72fa178cdf204e00d1074121ddc57fd4c5795ccc6335460409a245bca5c SHA512 46482a73b6d374cdd5881e9ed7a79199c85cb436cc700950c09541a94d61fc4f200613a34575e74d013409f0e42a7c1df4ed25ed65880f25cbebd926d47c6889
DIST bluefish-2.2.12.tar.bz2 4180228 BLAKE2B 9e05a4618c37951da6a669e9bd4e0dd7e9993ea764dd467f875039b28cdc6d71ae70d1a87df7f0c63f850ebbff6ceeb8550d1d036bab32b7435f362d5b137147 SHA512 f0eb6496d371db8a9b4aee33ddf67e5e87bcc86ff283704cac115be7f00609b1ccbd47ff2d8f8b0bc30f234a339069cc1f7cb1f8809d97f94f0b0e09e4f16754
-EBUILD bluefish-2.2.12.ebuild 2382 BLAKE2B 2fdedb0cdf138a9a65e6eae58474a1e81f60d12170bc0d5475ca1419bea3428ef6b4f4843f5c67b0297d966d11a8d1e64011bd261414f17a413a4c0afe81dae8 SHA512 9a49b547b46a052a305079a1beb8027e68d1a9da2b3d06c78df5fde26a273f3fef1ff6de0df88cfd27d61dfbc5a65fde291bdea89f63cbcb7a971d659992154d
+EBUILD bluefish-2.2.12-r1.ebuild 2459 BLAKE2B eec16cbac14d1e11d15212029ad6a85aab1f21c3be125d81fc9759438472f5766a389e123a10441fde17a5ca6a83af5cb22255944ac871a17f05c33a339a8dc2 SHA512 57420024d52dea27990dae3726f54981ede4279a8ca515d08def57c16b46e3a7b1fb4ecd6caacf6b4add5deba52f604d64c735f7ed890fb95bf57b2b1a946af1
+EBUILD bluefish-2.2.12.ebuild 2463 BLAKE2B 96e7b71add78bf5ac5e6888d6f27e9fe18502bfc6819653402119fe3adfd684654fd7d042cf6d25e8ed4fefa15a01dca26f14c085edc4ab539b0a64a81752a38 SHA512 6a8ad043ef2c2d1db89cea9f8ac3535678d4425207729c0facf67604d5f2fab9aae8a955f83a017d502ca7a92b0426ad577b7784013d2e44631ff12aea1ba1dc
MISC metadata.xml 333 BLAKE2B 5a5f339d26d78d99050d8324891a3d6ef97af31e3e6a397e763cc2e7561f892e43856e38fefe72be28db1962a4da153b0ebde42db6a53074bdf6b9c13eb74d87 SHA512 144b48f78b13ad3f07868b3171db5935431befd92821a6b70b6e626943996bcc4219ff27808b9062b2da4b5ff1c86dcb1c3778757b0b2a905c5bea3e90dcf152
diff --git a/app-editors/bluefish/bluefish-2.2.12-r1.ebuild b/app-editors/bluefish/bluefish-2.2.12-r1.ebuild
new file mode 100644
index 000000000000..02c2c22c45b3
--- /dev/null
+++ b/app-editors/bluefish/bluefish-2.2.12-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+MY_P=${P/_/-}
+inherit autotools python-single-r1 xdg
+
+DESCRIPTION="GTK HTML editor for the experienced web designer or programmer"
+HOMEPAGE="https://bluefish.openoffice.nl/"
+SRC_URI="https://www.bennewitz.com/bluefish/stable/source/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3+"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+SLOT="0"
+IUSE="gucharmap nls python spell"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="sys-libs/zlib
+ x11-libs/gtk+:3
+ gucharmap? ( gnome-extra/gucharmap:2.90 )
+ python? ( ${PYTHON_DEPS} )
+ spell? ( app-text/enchant:2 )"
+DEPEND="${RDEPEND}
+ x11-libs/pango"
+BDEPEND=">=dev-libs/glib-2.24:2
+ dev-libs/libxml2:2
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+# there actually is just some broken manpage checkup -> not bother
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${PN}-2.2.9-charmap_configure.patch" )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # eautoreconf seems to no longer kill translation files.
+ eautoreconf
+ sed -i 's:gzip -n $< -c:gzip -n -c $<:' data/bflib/Makefile.* || die "Cannot fix makefile"
+}
+
+src_configure() {
+ CONFIG_SHELL="${BROOT}/bin/bash" econf \
+ --disable-update-databases \
+ --disable-xml-catalog-update \
+ --with-freedesktop_org-appdata="${EPREFIX}"/usr/share/metainfo \
+ --without-gtk2 \
+ $(use_with gucharmap charmap) \
+ $(use_enable nls) \
+ $(use_enable spell spell-check) \
+ $(use_enable python)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ einfo "Adding XML catalog entries..."
+ "${EPREFIX}"/usr/bin/xmlcatalog --noout \
+ --add 'public' 'Bluefish/DTD/Bflang' 'bflang.dtd' \
+ --add 'system' 'http://bluefish.openoffice.nl/DTD/bflang.dtd' 'bflang.dtd' \
+ --add 'rewriteURI' 'http://bluefish.openoffice.nl/DTD' '/usr/share/xml/bluefish-unstable' \
+ "${EROOT}"/etc/xml/catalog \
+ || ewarn "Failed to add XML catalog entries."
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+
+ einfo "Removing XML catalog entries..."
+ "${EPREFIX}"/usr/bin/xmlcatalog --noout \
+ --del 'Bluefish/DTD/Bflang' \
+ --del 'http://bluefish.openoffice.nl/DTD/bflang.dtd' \
+ --del 'http://bluefish.openoffice.nl/DTD' \
+ "${EROOT}"/etc/xml/catalog \
+ || ewarn "Failed to remove XML catalog entries."
+}
diff --git a/app-editors/bluefish/bluefish-2.2.12.ebuild b/app-editors/bluefish/bluefish-2.2.12.ebuild
index 2580098daeac..5e75105359f7 100644
--- a/app-editors/bluefish/bluefish-2.2.12.ebuild
+++ b/app-editors/bluefish/bluefish-2.2.12.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
MY_P=${P/_/-}
inherit autotools python-single-r1 xdg
@@ -18,8 +18,7 @@ SLOT="0"
IUSE="gucharmap nls python spell"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RDEPEND="
- sys-libs/zlib
+RDEPEND="sys-libs/zlib
x11-libs/gtk+:3
gucharmap? ( gnome-extra/gucharmap:2.90 )
python? ( ${PYTHON_DEPS} )
@@ -30,8 +29,8 @@ BDEPEND=">=dev-libs/glib-2.24:2
dev-libs/libxml2:2
virtual/pkgconfig
nls? (
- sys-devel/gettext
dev-util/intltool
+ sys-devel/gettext
)"
S="${WORKDIR}/${MY_P}"
@@ -39,21 +38,22 @@ S="${WORKDIR}/${MY_P}"
# there actually is just some broken manpage checkup -> not bother
RESTRICT="test"
+PATCHES=( "${FILESDIR}/${PN}-2.2.9-charmap_configure.patch" )
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}
-PATCHES=( "${FILESDIR}/${PN}-2.2.9-charmap_configure.patch" )
-
-# eautoreconf seems to no longer kill translation files.
src_prepare() {
default
+
+ # eautoreconf seems to no longer kill translation files.
eautoreconf
sed -i 's:gzip -n $< -c:gzip -n -c $<:' data/bflib/Makefile.* || die "Cannot fix makefile"
}
src_configure() {
- econf \
+ CONFIG_SHELL="${BROOT}/bin/bash" econf \
--disable-update-databases \
--disable-xml-catalog-update \
--with-freedesktop_org-appdata="${EPREFIX}"/usr/share/metainfo \
@@ -66,27 +66,30 @@ src_configure() {
src_install() {
default
+
find "${ED}" -name '*.la' -delete || die
}
pkg_postinst() {
xdg_pkg_postinst
+
einfo "Adding XML catalog entries..."
- /usr/bin/xmlcatalog --noout \
+ "${EPREFIX}"/usr/bin/xmlcatalog --noout \
--add 'public' 'Bluefish/DTD/Bflang' 'bflang.dtd' \
--add 'system' 'http://bluefish.openoffice.nl/DTD/bflang.dtd' 'bflang.dtd' \
--add 'rewriteURI' 'http://bluefish.openoffice.nl/DTD' '/usr/share/xml/bluefish-unstable' \
- /etc/xml/catalog \
+ "${EROOT}"/etc/xml/catalog \
|| ewarn "Failed to add XML catalog entries."
}
pkg_postrm() {
xdg_pkg_postrm
+
einfo "Removing XML catalog entries..."
- /usr/bin/xmlcatalog --noout \
+ "${EPREFIX}"/usr/bin/xmlcatalog --noout \
--del 'Bluefish/DTD/Bflang' \
--del 'http://bluefish.openoffice.nl/DTD/bflang.dtd' \
--del 'http://bluefish.openoffice.nl/DTD' \
- /etc/xml/catalog \
+ "${EROOT}"/etc/xml/catalog \
|| ewarn "Failed to remove XML catalog entries."
}