summaryrefslogtreecommitdiff
path: root/app-editors/gedit-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-08 10:19:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-08 10:19:19 +0100
commit92ebda186167f9887d5f43803ced730b499dcf57 (patch)
treeee0e4261f26516d8b6bdaa4c330eee878d9ca136 /app-editors/gedit-plugins
parentd84be18029b166ee26fe5416098974a8d05b2983 (diff)
gentoo auto-resync : 08:07:2023 - 10:19:19
Diffstat (limited to 'app-editors/gedit-plugins')
-rw-r--r--app-editors/gedit-plugins/Manifest2
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-45.0.ebuild100
2 files changed, 102 insertions, 0 deletions
diff --git a/app-editors/gedit-plugins/Manifest b/app-editors/gedit-plugins/Manifest
index 97b05d3378ba..23a8c8f4bdb2 100644
--- a/app-editors/gedit-plugins/Manifest
+++ b/app-editors/gedit-plugins/Manifest
@@ -1,3 +1,5 @@
DIST gedit-plugins-44.1.tar.xz 913228 BLAKE2B a153b82da23f7838da9fa24b28687eae2fd0e4381693515f45e665fc6d9bc2715b37fa6bdac7a8a6ebd947ba0a3a70e5c12708bb14a053c9ad0384549e8ef4f6 SHA512 d5d767210b362747e4ba51b61b4d1c58bf5b37aa5f942cb9654f71c534d8bce2594ebc9004bed686627403fe1c3a6af84a45f4ce72af1f27fa7b644d11cdc9e2
+DIST gedit-plugins-45.0.tar.xz 902452 BLAKE2B 2569de052fee9401561e874a0387799c582fd69c177034595e9bb61c9ebd75fb6333b4bd7d1c8460d4bb13c5cb0c1ea8abeeaac1bf53f2279d4a920d71b5069e SHA512 41ada11d4cfc99d3f8edab46916490bfb6282c82bc35952331a5e920ffb8490c9ca543d459ed670390e4268bf2068b86382be4049443ce73cd4bb60b9a31b879
EBUILD gedit-plugins-44.1.ebuild 2587 BLAKE2B 89f009a541f6d10c06a8208b7521ac57c23675da04871d7f4b3396dce5527ef94ae7c8dba873d26a29fce038744163239f5fae985894638ac1ef7c03de9020f5 SHA512 62a9a0b4fc3e63dd50ceb089fba6629aa7b613da925982a96abe6773fb51267b4a8e53a75ff59323fc0ea52be31c3f786c57111dd91881a298b9e8913fe9d2be
+EBUILD gedit-plugins-45.0.ebuild 2449 BLAKE2B a90490a5770058f741dc08dc82fd231ac4a75db4a149d718cae1ee67ff2d36b6d6d222f6d8370acfbdc48e350e6fc352b62b9c5b49beb52c08f34de6c2c44c66 SHA512 04ac542fca66d5606fefce52d3a7d44af27bbff681650f59af2f1f86144cbac8f8a6ef202f3a7e447c6061e256900eeb4904bb62951425342f43a97a8d349ba1
MISC metadata.xml 596 BLAKE2B cf545e591c160fc584c5c2b1e3f5fa6a47922a958f981daa5c85f3f6c8f7eaed2a520d6265241998dfe211098f70c75a0fdfff033e55e892e5775b678ea9ef5b SHA512 0a3b9e748bc2d22ea16a694f8ebd6196d05e6652f552523bfe6fa60f1c69ab50110692cda7a59239c8f6946c06d3139a4225f1744e0dd40ccbdef3e8b396f692
diff --git a/app-editors/gedit-plugins/gedit-plugins-45.0.ebuild b/app-editors/gedit-plugins/gedit-plugins-45.0.ebuild
new file mode 100644
index 000000000000..a8aad8084b13
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-45.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="Collection of extra plugins for the gedit Text Editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ThirdPartyPlugins"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+SLOT="0"
+
+IUSE="charmap git +python terminal vala"
+REQUIRED_USE="
+ charmap? ( python )
+ git? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ terminal? ( python )
+"
+
+RDEPEND="
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=app-editors/gedit-45.0
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.9:3
+ gui-libs/libgedit-gtksourceview:300
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-editors/gedit[python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ >=dev-python/dbus-python-0.82[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ ')
+ >=x11-libs/gtk+-3.9:3[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ )
+ charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
+ git? ( >=dev-libs/libgit2-glib-0.0.6[python] )
+ terminal? ( >=x11-libs/vte-0.52:2.91[introspection] )
+" # vte-0.52+ for feed_child API compatibility
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dplugin_bookmarks=true
+ $(meson_use python plugin_bracketcompletion)
+ $(meson_use charmap plugin_charmap)
+ $(meson_use python plugin_codecomment)
+ $(meson_use python plugin_colorpicker)
+ -Dplugin_drawspaces=true
+ $(meson_use git plugin_git)
+ $(meson_use python plugin_joinlines)
+ $(meson_use python plugin_multiedit)
+ $(meson_use python plugin_sessionsaver)
+ -Dplugin_smartspaces=true
+ $(meson_use terminal plugin_terminal)
+ $(meson_use python plugin_textsize)
+ -Dplugin_wordcompletion=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ use python && python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}