summaryrefslogtreecommitdiff
path: root/app-emacs/a
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-12 15:25:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-12 15:25:12 +0000
commitdeac3ec728eccad6c6929b2699ced3580deeadcd (patch)
tree1b2bd95136e398dcc801453323b2dad3ce3d3949 /app-emacs/a
parent09d1923fc1fee6007fbd5692399ffa7fbff7e410 (diff)
gentoo auto-resync : 12:12:2022 - 15:25:12
Diffstat (limited to 'app-emacs/a')
-rw-r--r--app-emacs/a/Manifest4
-rw-r--r--app-emacs/a/a-1.0.0.ebuild29
-rw-r--r--app-emacs/a/files/50a-gentoo.el1
-rw-r--r--app-emacs/a/metadata.xml17
4 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/a/Manifest b/app-emacs/a/Manifest
new file mode 100644
index 000000000000..c5b0fd24c47b
--- /dev/null
+++ b/app-emacs/a/Manifest
@@ -0,0 +1,4 @@
+AUX 50a-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST a.el-1.0.0.tar.gz 19740 BLAKE2B c5bb72fd206b1b33798c90982f7111f7cd100e6e36580bce267b6d6295a82b536a00cddeed3cf9bf94964b451429769f705358a731cbe5054a2683fc90d4bf14 SHA512 3a795fb2cf613bafabbf2c788dc1edd4dbd26871043a9225f3db61542f1d5c95102355d9223498dc4dbe5aba446e9b8a22437b6e6799c3a0f2ad213bc35b2556
+EBUILD a-1.0.0.ebuild 642 BLAKE2B 649f245dc151eec048bb3dd67fb94678be30aade5733aaff1465e72b929678016cc76d554956d4b59e3665764c33e2dd26dbb5231680b3468a8340220b8e2f2b SHA512 690d58f2d5b7ae05fabbf5ff088c48baee79694ac2f987917c42fcae69ec8b53a799a7f4c2a36e2f3bd6cbc771836f1cb0e9be8160951f57d73b1768fcbcd8cb
+MISC metadata.xml 593 BLAKE2B 58d0e7438e7d43af9b2bc9b998cb80cfc7328988f421bab49fc0147b8edd0d85938dff46fac08e5c123f74d81cbd5e83a13d8de5f65a12f1beb134fc3677ba6e SHA512 9c00a6a7554c7000cff70b36f9cae8da18b6dbedd1b8a9cedd478da2028ecb00bc44567b75f21b79c3e1768aa9b01d4521e7fda6f23edb31610b4919ac5789ac
diff --git a/app-emacs/a/a-1.0.0.ebuild b/app-emacs/a/a-1.0.0.ebuild
new file mode 100644
index 000000000000..a6fe49e7363f
--- /dev/null
+++ b/app-emacs/a/a-1.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Associative data structure functions for Emacs Lisp"
+HOMEPAGE="https://github.com/plexus/a.el/"
+SRC_URI="https://github.com/plexus/a.el/archive/v${PV}.tar.gz
+ -> a.el-${PV}.tar.gz"
+S="${WORKDIR}"/a.el-${PV}
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/ert-runner )"
+
+DOCS=( CHANGELOG.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}
diff --git a/app-emacs/a/files/50a-gentoo.el b/app-emacs/a/files/50a-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/a/files/50a-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/a/metadata.xml b/app-emacs/a/metadata.xml
new file mode 100644
index 000000000000..3a987898ee9d
--- /dev/null
+++ b/app-emacs/a/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Emacs Lisp functions for dealing with associative structures in a uniform
+ and functional way. Inspired by Clojure, dash, and seq.el.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/plexus/a.el/issues/</bugs-to>
+ <remote-id type="github">plexus/a.el</remote-id>
+ </upstream>
+</pkgmetadata>