summaryrefslogtreecommitdiff
path: root/app-emacs/doom-modeline
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-20 00:00:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-20 00:00:11 +0000
commitca7fcaa76aaf1f94284894a8d9a01bb153e80b11 (patch)
treedcfb443cd20285c353c22c05f43f96ca3d3161a8 /app-emacs/doom-modeline
parent150a86a9cb006b4800d6517d58532b8a556fec1e (diff)
gentoo auto-resync : 20:01:2023 - 00:00:11
Diffstat (limited to 'app-emacs/doom-modeline')
-rw-r--r--app-emacs/doom-modeline/Manifest4
-rw-r--r--app-emacs/doom-modeline/doom-modeline-3.3.2.ebuild41
-rw-r--r--app-emacs/doom-modeline/files/50doom-modeline-gentoo.el2
-rw-r--r--app-emacs/doom-modeline/metadata.xml13
4 files changed, 60 insertions, 0 deletions
diff --git a/app-emacs/doom-modeline/Manifest b/app-emacs/doom-modeline/Manifest
new file mode 100644
index 000000000000..cff61bee753e
--- /dev/null
+++ b/app-emacs/doom-modeline/Manifest
@@ -0,0 +1,4 @@
+AUX 50doom-modeline-gentoo.el 77 BLAKE2B 0b7e10cff2a5e20083f8ba376e3e72ea1fc423cb8fa605b59cfc601aac72fe8611a6b558924c52b1f74ef2413d2efea806c929fa1d4b8b212cabbb9ef62d730f SHA512 6dc0e3ec4c48923a850466c86b97a63472e0861dcd8bfc8d346cac17e3cf1f0aa03fe0c3d9b75efaa73ec919073024320d3b4cfc17e8c1a2c0b2a17a43c72339
+DIST doom-modeline-3.3.2.tar.gz 61363 BLAKE2B 2b80748265f911954e1726dc30e6bacf4ba7ffb6eb589e8f67c366b818e212376039eb025d380937b327f7d3d4a980ec6bfe0589ac38af1e0d678a8f6038b97f SHA512 ff0b41c5f8dc7e5a4a5bccaa710b445a1894948893cd7dea6c564d3a9b1be5cd7cd005e6a28613a6800526d5158faebfef51d21b9e911d97416821210954f0b3
+EBUILD doom-modeline-3.3.2.ebuild 923 BLAKE2B ab5471a1068cb164c95e846ecd78c1e63156c2205bd2a3a331e86f4c752a71c3f4c7439a1f637ec9bf1ff7bf2d6d0138629013f416bcd40ee51ab0ccb477aa5c SHA512 1b412ecc2f06a0871ecbbbeddb3ab379d782d1a8eb278c606d1a00d8504c500816086fa538f6e9b107ff4b579e7a6176828d1b3cb7ad47ecc90c5c41e72cbf60
+MISC metadata.xml 437 BLAKE2B 4510e1869b8871d0c054ec00c7c639125d52f451ffc129fe5a8255026ddd3c2fe36d8e9f5ef9a47c7f0b87b356d67e16cc2ab84b6414b7399b402df3fb0d3d89 SHA512 cda6737b5873ec737482048c543f9a5e8a8137d13072d663c8b714e0607c47c8d77ffdef9a2d9c8713c0c321c0e7bd3cd1531546f53c045000853badd575e61e
diff --git a/app-emacs/doom-modeline/doom-modeline-3.3.2.ebuild b/app-emacs/doom-modeline/doom-modeline-3.3.2.ebuild
new file mode 100644
index 000000000000..8699aa390639
--- /dev/null
+++ b/app-emacs/doom-modeline/doom-modeline-3.3.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="Fancy and fast mode-line for Emacs inspired by minimalism design"
+HOMEPAGE="https://seagle0128.github.io/doom-modeline/
+ https://github.com/seagle0128/doom-modeline/"
+SRC_URI="https://github.com/seagle0128/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ app-emacs/all-the-icons
+ app-emacs/compat
+ app-emacs/shrink-path
+"
+BDEPEND="${RDEPEND}"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
+ -L . -L test \
+ -l test/${PN}-core-test.el \
+ -l test/${PN}-env-test.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}
diff --git a/app-emacs/doom-modeline/files/50doom-modeline-gentoo.el b/app-emacs/doom-modeline/files/50doom-modeline-gentoo.el
new file mode 100644
index 000000000000..0dd9efab6129
--- /dev/null
+++ b/app-emacs/doom-modeline/files/50doom-modeline-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "doom-modeline-autoloads" nil t)
diff --git a/app-emacs/doom-modeline/metadata.xml b/app-emacs/doom-modeline/metadata.xml
new file mode 100644
index 000000000000..e8b3def7a3b9
--- /dev/null
+++ b/app-emacs/doom-modeline/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/seagle0128/doom-modeline/issues/</bugs-to>
+ <remote-id type="github">seagle0128/doom-modeline</remote-id>
+ </upstream>
+</pkgmetadata>