summaryrefslogtreecommitdiff
path: root/app-emacs/god-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-07 23:37:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-07 23:37:50 +0100
commit8dfbaa8100b5c51e1de0e4e476ef5513e3ed1bdd (patch)
tree6514153552d2daad7d178ee75d47332710e2979e /app-emacs/god-mode
parent2fe5661a32d6ec0ba1d6b37cc8ae67e3f81459ec (diff)
gentoo auto-resync : 07:05:2023 - 23:37:50
Diffstat (limited to 'app-emacs/god-mode')
-rw-r--r--app-emacs/god-mode/Manifest4
-rw-r--r--app-emacs/god-mode/files/50god-mode-gentoo.el9
-rw-r--r--app-emacs/god-mode/god-mode-2.18.0.ebuild33
-rw-r--r--app-emacs/god-mode/metadata.xml19
4 files changed, 65 insertions, 0 deletions
diff --git a/app-emacs/god-mode/Manifest b/app-emacs/god-mode/Manifest
new file mode 100644
index 000000000000..05d9ab2f4264
--- /dev/null
+++ b/app-emacs/god-mode/Manifest
@@ -0,0 +1,4 @@
+AUX 50god-mode-gentoo.el 402 BLAKE2B 1b11908fbecdaeabd68b4fa244f9055e8c5ed2c29f739096fed698a47cfad5f52a4290015b3e5b3fd544b670a91c05158d23b67c2547f52d3452d56d2fb758fd SHA512 74211494ebe61657eed9696c535890b8bacc9baa976def4edce89f8c17298ecfeebefe711fb8503ac138a807e3aa289fd8b83919271b27aa3302c7eeaee0f770
+DIST god-mode-2.18.0.tar.gz 27122 BLAKE2B b6af161fa3276e9393d44f4dd92393b0eb7239e49e29e3ba917e9b7f23b63d1d3432773dbfa075ed072a626c2bbd12c11625ec0dccb0733c58984b3f990add5d SHA512 3bcf170697cea8748f683a20e71e434efe4200dd72478568a370ea9f9c5658475b554f3fa5f2f79eaff443bd02fa0595389e4fb05af05d99f3bc891af46c224b
+EBUILD god-mode-2.18.0.ebuild 682 BLAKE2B 77d3ae4871cf34dd99189dbcc2b298c4374039fe85a24ce2fb615a5c2d7db16137d64a47049dfb1b6a3035b27a9d895749e68cfeebe390beef13c4b8bb45212d SHA512 8934de349c7b49dbedcd847166979f67140ec154bc4eb8e34e547664ed04fb002f19350505c573fd6c088c4d1f6f2e9514ffc505d0256436e2cafaabc1d08731
+MISC metadata.xml 741 BLAKE2B 66a7cd511f9e4bf95bf32f6974f5f84749e5c34d3817cdc605ab5f5a332c3d9b3f4173110a2c68839ab17d9f2db63adfa793ce36b8773a0395ccdc943ab7a7d2 SHA512 33c187e4f4e4728096cc7c6b76cccd46d0fb8022e161b80c8889ade8c41bac1250cb9d936e49348a89888e73167abfe5f962c3b801e7278e54d6df568ff0145c
diff --git a/app-emacs/god-mode/files/50god-mode-gentoo.el b/app-emacs/god-mode/files/50god-mode-gentoo.el
new file mode 100644
index 000000000000..46f7a9b1f48f
--- /dev/null
+++ b/app-emacs/god-mode/files/50god-mode-gentoo.el
@@ -0,0 +1,9 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'god-execute-with-current-bindings "god-mode"
+ "Execute a single command from God mode, preserving current keybindings." t)
+(autoload 'god-local-mode "god-mode"
+ "Minor mode for running commands." t)
+(autoload 'god-mode "god-mode"
+ "Toggle global `god-local-mode'." t)
+(autoload 'god-mode-all "god-mode"
+ "Toggle `god-local-mode' in all buffers." t)
diff --git a/app-emacs/god-mode/god-mode-2.18.0.ebuild b/app-emacs/god-mode/god-mode-2.18.0.ebuild
new file mode 100644
index 000000000000..661e49b70103
--- /dev/null
+++ b/app-emacs/god-mode/god-mode-2.18.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Minor mode for God-like command entering in GNU Emacs"
+HOMEPAGE="https://github.com/emacsorphanage/god-mode/"
+SRC_URI="https://github.com/emacsorphanage/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-emacs/ansi
+ app-emacs/ecukes
+ app-emacs/ecukes
+ app-emacs/f
+ )
+"
+
+DOCS=( .github/CONTRIBUTING.md .github/README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ecukes --debug --reporter spec --verbose || die "tests failed"
+}
diff --git a/app-emacs/god-mode/metadata.xml b/app-emacs/god-mode/metadata.xml
new file mode 100644
index 000000000000..754124d4374f
--- /dev/null
+++ b/app-emacs/god-mode/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This is a global minor mode for entering Emacs commands without modifier
+ keys. It's similar to Vim's separation of command mode and insert mode. All
+ existing key bindings will work in God mode. It's only there to reduce your
+ usage of modifier keys.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/emacsorphanage/god-mode/issues/</bugs-to>
+ <remote-id type="github">emacsorphanage/god-mode</remote-id>
+ </upstream>
+</pkgmetadata>