summaryrefslogtreecommitdiff
path: root/app-emacs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-07 23:37:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-07 23:37:50 +0100
commit8dfbaa8100b5c51e1de0e4e476ef5513e3ed1bdd (patch)
tree6514153552d2daad7d178ee75d47332710e2979e /app-emacs
parent2fe5661a32d6ec0ba1d6b37cc8ae67e3f81459ec (diff)
gentoo auto-resync : 07:05:2023 - 23:37:50
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/Manifest.gzbin68011 -> 68482 bytes
-rw-r--r--app-emacs/god-mode/Manifest4
-rw-r--r--app-emacs/god-mode/files/50god-mode-gentoo.el9
-rw-r--r--app-emacs/god-mode/god-mode-2.18.0.ebuild33
-rw-r--r--app-emacs/god-mode/metadata.xml19
-rw-r--r--app-emacs/kind-icon/Manifest4
-rw-r--r--app-emacs/kind-icon/files/50kind-icon-gentoo.el3
-rw-r--r--app-emacs/kind-icon/kind-icon-0.1.9.ebuild26
-rw-r--r--app-emacs/kind-icon/metadata.xml20
-rw-r--r--app-emacs/svg-lib/Manifest4
-rw-r--r--app-emacs/svg-lib/files/50svg-lib-gentoo.el3
-rw-r--r--app-emacs/svg-lib/metadata.xml20
-rw-r--r--app-emacs/svg-lib/svg-lib-0.2.5.ebuild24
13 files changed, 169 insertions, 0 deletions
diff --git a/app-emacs/Manifest.gz b/app-emacs/Manifest.gz
index 45230942e33f..aa279d2fcff3 100644
--- a/app-emacs/Manifest.gz
+++ b/app-emacs/Manifest.gz
Binary files differ
diff --git a/app-emacs/god-mode/Manifest b/app-emacs/god-mode/Manifest
new file mode 100644
index 000000000000..05d9ab2f4264
--- /dev/null
+++ b/app-emacs/god-mode/Manifest
@@ -0,0 +1,4 @@
+AUX 50god-mode-gentoo.el 402 BLAKE2B 1b11908fbecdaeabd68b4fa244f9055e8c5ed2c29f739096fed698a47cfad5f52a4290015b3e5b3fd544b670a91c05158d23b67c2547f52d3452d56d2fb758fd SHA512 74211494ebe61657eed9696c535890b8bacc9baa976def4edce89f8c17298ecfeebefe711fb8503ac138a807e3aa289fd8b83919271b27aa3302c7eeaee0f770
+DIST god-mode-2.18.0.tar.gz 27122 BLAKE2B b6af161fa3276e9393d44f4dd92393b0eb7239e49e29e3ba917e9b7f23b63d1d3432773dbfa075ed072a626c2bbd12c11625ec0dccb0733c58984b3f990add5d SHA512 3bcf170697cea8748f683a20e71e434efe4200dd72478568a370ea9f9c5658475b554f3fa5f2f79eaff443bd02fa0595389e4fb05af05d99f3bc891af46c224b
+EBUILD god-mode-2.18.0.ebuild 682 BLAKE2B 77d3ae4871cf34dd99189dbcc2b298c4374039fe85a24ce2fb615a5c2d7db16137d64a47049dfb1b6a3035b27a9d895749e68cfeebe390beef13c4b8bb45212d SHA512 8934de349c7b49dbedcd847166979f67140ec154bc4eb8e34e547664ed04fb002f19350505c573fd6c088c4d1f6f2e9514ffc505d0256436e2cafaabc1d08731
+MISC metadata.xml 741 BLAKE2B 66a7cd511f9e4bf95bf32f6974f5f84749e5c34d3817cdc605ab5f5a332c3d9b3f4173110a2c68839ab17d9f2db63adfa793ce36b8773a0395ccdc943ab7a7d2 SHA512 33c187e4f4e4728096cc7c6b76cccd46d0fb8022e161b80c8889ade8c41bac1250cb9d936e49348a89888e73167abfe5f962c3b801e7278e54d6df568ff0145c
diff --git a/app-emacs/god-mode/files/50god-mode-gentoo.el b/app-emacs/god-mode/files/50god-mode-gentoo.el
new file mode 100644
index 000000000000..46f7a9b1f48f
--- /dev/null
+++ b/app-emacs/god-mode/files/50god-mode-gentoo.el
@@ -0,0 +1,9 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'god-execute-with-current-bindings "god-mode"
+ "Execute a single command from God mode, preserving current keybindings." t)
+(autoload 'god-local-mode "god-mode"
+ "Minor mode for running commands." t)
+(autoload 'god-mode "god-mode"
+ "Toggle global `god-local-mode'." t)
+(autoload 'god-mode-all "god-mode"
+ "Toggle `god-local-mode' in all buffers." t)
diff --git a/app-emacs/god-mode/god-mode-2.18.0.ebuild b/app-emacs/god-mode/god-mode-2.18.0.ebuild
new file mode 100644
index 000000000000..661e49b70103
--- /dev/null
+++ b/app-emacs/god-mode/god-mode-2.18.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Minor mode for God-like command entering in GNU Emacs"
+HOMEPAGE="https://github.com/emacsorphanage/god-mode/"
+SRC_URI="https://github.com/emacsorphanage/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-emacs/ansi
+ app-emacs/ecukes
+ app-emacs/ecukes
+ app-emacs/f
+ )
+"
+
+DOCS=( .github/CONTRIBUTING.md .github/README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ecukes --debug --reporter spec --verbose || die "tests failed"
+}
diff --git a/app-emacs/god-mode/metadata.xml b/app-emacs/god-mode/metadata.xml
new file mode 100644
index 000000000000..754124d4374f
--- /dev/null
+++ b/app-emacs/god-mode/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This is a global minor mode for entering Emacs commands without modifier
+ keys. It's similar to Vim's separation of command mode and insert mode. All
+ existing key bindings will work in God mode. It's only there to reduce your
+ usage of modifier keys.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/emacsorphanage/god-mode/issues/</bugs-to>
+ <remote-id type="github">emacsorphanage/god-mode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/kind-icon/Manifest b/app-emacs/kind-icon/Manifest
new file mode 100644
index 000000000000..fd5c89be9310
--- /dev/null
+++ b/app-emacs/kind-icon/Manifest
@@ -0,0 +1,4 @@
+AUX 50kind-icon-gentoo.el 160 BLAKE2B 172306977f0fefb5a50499d7de9dab64f90e1004ef259ec253d7ea94cca670cb1f33849fe282b290413b0a7715f40c5dc72c72b8a474b4d2e64db249c7ecbca8 SHA512 fd8a2f37b43f8747533d25a773c4a849e59e0b420ef1f4eff4f9daa97f91aa56d41f0a803e6cd8cb9a2161fa62ac9ac5966542701d4a15005506b323c16e4eb2
+DIST kind-icon-0.1.9.tar.lz 19417 BLAKE2B 9d1590627d1d6bff65af9d0658a0aed9245f43b9d27abc57fdc43edae200f8d5fff993d43d0eae84499975a847fae069d706fd47cb0f7b81406f220fd047bfb4 SHA512 b9cd384399eadd898001ae502315b0c78efb483ccb4414f41eab51cfd2a18a98a53618507f6d2bd5c7f6758a358d744b143f00a7912237efcc9451591505933e
+EBUILD kind-icon-0.1.9.ebuild 544 BLAKE2B 98c10b72963e7b6797797de7ae7d3522f6ab2fb1c131570857ef2ba1e179c6c00bec21a358d386689524b3eb259ba3b4882c7b92dd7cec4822d0114292b60599 SHA512 3198f603eff56ac0f01de049278fd8fc4aaf08a13656be5f867c33492b434edf02956b997b5d453b2247e9ce5d503df83295ae93d95a41943ef859fa4c30555c
+MISC metadata.xml 578 BLAKE2B e5e0450ac488021d88a578f1322cdeea8a94bb2d2dacfd3f84b75addf0c5506a3f78418cc35f72eb0e38cba4f507acc6de3d5ae24676c7f5e9cb0e88501fb7e3 SHA512 477e1571f256bef169893ee7a23541f7a0f1e1dd37c4df7a30a5d9461c082570bdc4b8a8eef6588643e8b968ac82c63ee2307247b04be4252e3f89689fc1e43b
diff --git a/app-emacs/kind-icon/files/50kind-icon-gentoo.el b/app-emacs/kind-icon/files/50kind-icon-gentoo.el
new file mode 100644
index 000000000000..b9e72be87371
--- /dev/null
+++ b/app-emacs/kind-icon/files/50kind-icon-gentoo.el
@@ -0,0 +1,3 @@
+;;; app-emacs/kind-icon site configuration -*- lexical-binding: t; -*-
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/kind-icon-autoloads.el" nil t)
diff --git a/app-emacs/kind-icon/kind-icon-0.1.9.ebuild b/app-emacs/kind-icon/kind-icon-0.1.9.ebuild
new file mode 100644
index 000000000000..eb4ee87bfc08
--- /dev/null
+++ b/app-emacs/kind-icon/kind-icon-0.1.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="27.1"
+inherit elisp unpacker
+
+DESCRIPTION="Completion kind icons"
+HOMEPAGE="https://github.com/jdtsmith/kind-icon"
+SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-emacs/svg-lib"
+DEPEND="${RDEPEND}"
+BDEPEND="$(unpacker_src_uri_depends)"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+}
diff --git a/app-emacs/kind-icon/metadata.xml b/app-emacs/kind-icon/metadata.xml
new file mode 100644
index 000000000000..fda2bb3e66ad
--- /dev/null
+++ b/app-emacs/kind-icon/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>arsen@gentoo.org</email>
+ <name>Arsen Arsenović</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">jdtsmith/kind-icon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/svg-lib/Manifest b/app-emacs/svg-lib/Manifest
new file mode 100644
index 000000000000..1f6def16c92e
--- /dev/null
+++ b/app-emacs/svg-lib/Manifest
@@ -0,0 +1,4 @@
+AUX 50svg-lib-gentoo.el 158 BLAKE2B 138272c9c96e159663770419b2bff20ac9376d712245e6d55438b42537c75a53422c1a9bcf184931914befc88e10f7a5e5e171e3122d2d1f9dba08b28ebd9c6d SHA512 e302e618ba804c6e74bae7044ae9c6a9ba6cc06e77d4bbd0d0aac6643141f93db0ea83564d6f6133b032523996df34f8c6a7d61d58cd65d3d844e6c346b5f578
+DIST svg-lib-0.2.5.tar.lz 659528 BLAKE2B c02ad940f75b4de2475c16efd6acdfaa69af948fb81fc147d96cd9ee72a7fcef3f42438fc1a29ba351414306108eeb09f0a0be2aabf351c9d81f064b3dcb7d85 SHA512 306b8fa9464286cca7c77b1d5a9cc273661dc4f8fb0671d5ff6f57e9db95518531a8ce0d38dc20aa1d4820a23c9c5fd5bc725c5ff19391a62dcab74cee235a97
+EBUILD svg-lib-0.2.5.ebuild 503 BLAKE2B 16efeddeca31164330804098a4b97bf18f17230e6c11cca66ab67ac1a692fc02c0dd052e40220b3d2b8518130c0ca5e0af07a4bc591c9b4ad1bf28742112322e SHA512 f07dd2a95ca8a5dbfb683da0af53a27ad2dfc32f7e160f903ac587f9a8649f68f9fb261943bdc44fc0986c585c72e3e9798587b5b6841321e35594ebf0fc24e8
+MISC metadata.xml 575 BLAKE2B 5ce5aeff87a6130dc067c13f1ed3e8586f4b2e172440d7e03a17928029dd0b709454b152d98251ee0259acb63fda684396a3ec1d6d21a020fdf56746efa31cc5 SHA512 2ba8072cbb061cd69793dfccfc1f0934647c533ea6f1f61caf729a3a28eb961b522ca81e4d892d730e7395597396ce7d6e2358fee43fb5a1a27e1c1950577087
diff --git a/app-emacs/svg-lib/files/50svg-lib-gentoo.el b/app-emacs/svg-lib/files/50svg-lib-gentoo.el
new file mode 100644
index 000000000000..3f6bbeef5d56
--- /dev/null
+++ b/app-emacs/svg-lib/files/50svg-lib-gentoo.el
@@ -0,0 +1,3 @@
+;;; app-emacs/svg-lib site configuration -*- lexical-binding: t; -*-
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/svg-lib-autoloads.el" nil t)
diff --git a/app-emacs/svg-lib/metadata.xml b/app-emacs/svg-lib/metadata.xml
new file mode 100644
index 000000000000..2a9db088749f
--- /dev/null
+++ b/app-emacs/svg-lib/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>arsen@gentoo.org</email>
+ <name>Arsen Arsenović</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">rougier/svg-lib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/svg-lib/svg-lib-0.2.5.ebuild b/app-emacs/svg-lib/svg-lib-0.2.5.ebuild
new file mode 100644
index 000000000000..c392b21873b6
--- /dev/null
+++ b/app-emacs/svg-lib/svg-lib-0.2.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="27.1"
+inherit elisp unpacker
+
+DESCRIPTION="SVG tags, progress bars & icons"
+HOMEPAGE="https://github.com/rougier/svg-lib"
+SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="$(unpacker_src_uri_depends)"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+}