summaryrefslogtreecommitdiff
path: root/app-misc/imgurbash2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /app-misc/imgurbash2
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'app-misc/imgurbash2')
-rw-r--r--app-misc/imgurbash2/Manifest4
-rw-r--r--app-misc/imgurbash2/imgurbash2-2.1.ebuild29
-rw-r--r--app-misc/imgurbash2/imgurbash2-9999.ebuild29
-rw-r--r--app-misc/imgurbash2/metadata.xml15
4 files changed, 77 insertions, 0 deletions
diff --git a/app-misc/imgurbash2/Manifest b/app-misc/imgurbash2/Manifest
new file mode 100644
index 000000000000..ad32e0e4a0fc
--- /dev/null
+++ b/app-misc/imgurbash2/Manifest
@@ -0,0 +1,4 @@
+DIST imgurbash2-2.1.tar.gz 3619 BLAKE2B 01bb37615184113082a87b79b5bbda1707e36d8f4a28715e0686eb63f8d7c55f7aa760ecab9ab2457c1601e9cb0ff4b558cd08f8a77a123cfe97d8008ad1aa93 SHA512 32e7c39d3456f3d540af2db8b21d8a5724bf9b1db372953f3dd0ed21a6f7529209ec7afffe22410be46a99753202aca2454732d09c1314350187c5610b36ab9d
+EBUILD imgurbash2-2.1.ebuild 604 BLAKE2B b59d77dcfe8dab3d3d3f527618202ec252f8734d3df91fdbc8e7fed2e8871bd29e462dc8a641b1c5e6c27735507ddd925ea345111b7bcfb3dadab8233cacfff4 SHA512 bc052a2c24c485ec2afc2a4ef13d2c2ed99eba4d442802c3b7725724bb7c5f69c247ab44533d86bffa2200d86bb53f01d3988814dbac4a4d2ff430d68c1f16d4
+EBUILD imgurbash2-9999.ebuild 604 BLAKE2B b59d77dcfe8dab3d3d3f527618202ec252f8734d3df91fdbc8e7fed2e8871bd29e462dc8a641b1c5e6c27735507ddd925ea345111b7bcfb3dadab8233cacfff4 SHA512 bc052a2c24c485ec2afc2a4ef13d2c2ed99eba4d442802c3b7725724bb7c5f69c247ab44533d86bffa2200d86bb53f01d3988814dbac4a4d2ff430d68c1f16d4
+MISC metadata.xml 446 BLAKE2B d320d9d38032271643c158fa8bd5e356c41a2fa3d91c375eb58a42084f2d202a3728a4b49e2826111bf01de57c5e451b82be8cd8c11ce40f4ab86a41981839d7 SHA512 f5d5aa394eac1885bc1aec85009b73bce9f875ede01719a234a84d8a311441e372288abf04d993263828b0bdabee6da1ab81c7ebd70f1100f5c4c17a0ca6e1de
diff --git a/app-misc/imgurbash2/imgurbash2-2.1.ebuild b/app-misc/imgurbash2/imgurbash2-2.1.ebuild
new file mode 100644
index 000000000000..076690d530e5
--- /dev/null
+++ b/app-misc/imgurbash2/imgurbash2-2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ram-on/imgurbash2.git"
+else
+ SRC_URI="https://github.com/ram-on/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Bash script that uploads/deletes images to/from imgur"
+HOMEPAGE="https://github.com/ram-on/imgurbash2"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="X"
+
+RDEPEND="
+ net-misc/curl
+ X? ( || ( x11-misc/xclip x11-misc/xsel ) )
+"
+
+src_install() {
+ einstalldocs
+ dobin imgurbash2
+}
diff --git a/app-misc/imgurbash2/imgurbash2-9999.ebuild b/app-misc/imgurbash2/imgurbash2-9999.ebuild
new file mode 100644
index 000000000000..076690d530e5
--- /dev/null
+++ b/app-misc/imgurbash2/imgurbash2-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ram-on/imgurbash2.git"
+else
+ SRC_URI="https://github.com/ram-on/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Bash script that uploads/deletes images to/from imgur"
+HOMEPAGE="https://github.com/ram-on/imgurbash2"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="X"
+
+RDEPEND="
+ net-misc/curl
+ X? ( || ( x11-misc/xclip x11-misc/xsel ) )
+"
+
+src_install() {
+ einstalldocs
+ dobin imgurbash2
+}
diff --git a/app-misc/imgurbash2/metadata.xml b/app-misc/imgurbash2/metadata.xml
new file mode 100644
index 000000000000..080521c63d58
--- /dev/null
+++ b/app-misc/imgurbash2/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lucianposton@pm.me</email>
+ <name>Lucian Poston</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ram-on/imgurbash2</remote-id>
+ </upstream>
+</pkgmetadata>