summaryrefslogtreecommitdiff
path: root/app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
commitefca79f216bfeffd55e7731fbf24126d093e1084 (patch)
treef19ba31d8686b3de4192db3e4c4dc9f3d9af54b5 /app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r2.ebuild
parentea7f3f690b55cdfa8b2d350b03c1dfc0c8357a51 (diff)
gentoo auto-resync : 15:09:2023 - 04:49:10
Diffstat (limited to 'app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r2.ebuild')
-rw-r--r--app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r2.ebuild b/app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r2.ebuild
new file mode 100644
index 000000000000..28e337173b22
--- /dev/null
+++ b/app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: fluxbox files syntax and indent"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=679"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="app-vim/genindent"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting and indent settings for fluxbox
+menus and similar files. Upstream don't provide us with an ftdetect file,
+but a simple one has been created for you by this ebuild. You can manually
+set the filetype using :set filetype=fluxbox if necessary."
+
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ mkdir ftdetect || die
+ echo "au BufNewFile,BufRead /*/*fluxbox/*menu set filetype=fluxbox" \
+ > ftdetect/fluxbox.vim || die
+}