summaryrefslogtreecommitdiff
path: root/app-vim/tagbar/tagbar-2.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-21 02:09:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-21 02:09:25 +0000
commitafcb9236a72cf602364c28b9bde6648e4a7f1ca5 (patch)
tree9608aa2c881b2688207832334c938f0e38d5c71c /app-vim/tagbar/tagbar-2.7-r1.ebuild
parentd3419aa304ff2564036398be5e8ed4bdeaeaa007 (diff)
gentoo auto-resync : 21:01:2024 - 02:09:25
Diffstat (limited to 'app-vim/tagbar/tagbar-2.7-r1.ebuild')
-rw-r--r--app-vim/tagbar/tagbar-2.7-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/app-vim/tagbar/tagbar-2.7-r1.ebuild b/app-vim/tagbar/tagbar-2.7-r1.ebuild
new file mode 100644
index 000000000000..d3ad7238cf7f
--- /dev/null
+++ b/app-vim/tagbar/tagbar-2.7-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: display tags of the current file ordered by scope"
+HOMEPAGE="
+ https://github.com/preservim/tagbar
+ https://www.vim.org/scripts/script.php?script_id=3465
+"
+SRC_URI="https://github.com/preservim/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-util/ctags-5.5"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"