summaryrefslogtreecommitdiff
path: root/dev-haskell/crypton/crypton-0.32.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/crypton/crypton-0.32.ebuild
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/crypton/crypton-0.32.ebuild')
-rw-r--r--dev-haskell/crypton/crypton-0.32.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-haskell/crypton/crypton-0.32.ebuild b/dev-haskell/crypton/crypton-0.32.ebuild
new file mode 100644
index 000000000000..baf8e2b05f65
--- /dev/null
+++ b/dev-haskell/crypton/crypton-0.32.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Cryptography Primitives sink"
+HOMEPAGE="https://github.com/kazu-yamamoto/crypton"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="check-alignment +integer-gmp old-toolchain-inliner +support-aesni +support-deepseq +support-pclmuldq +support-rdrand support-sse +target-attributes"
+
+RDEPEND=">=dev-haskell/basement-0.0.6:=[profile?]
+ >=dev-haskell/memory-0.14.18:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ virtual/libc
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-kat
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag check-alignment check_alignment) \
+ $(cabal_flag integer-gmp integer-gmp) \
+ $(cabal_flag old-toolchain-inliner old_toolchain_inliner) \
+ $(cabal_flag support-aesni support_aesni) \
+ $(cabal_flag support-deepseq support_deepseq) \
+ $(cabal_flag support-pclmuldq support_pclmuldq) \
+ $(cabal_flag support-rdrand support_rdrand) \
+ $(cabal_flag support-sse support_sse) \
+ $(cabal_flag target-attributes use_target_attributes)
+}