summaryrefslogtreecommitdiff
path: root/dev-haskell/optparse-applicative
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/optparse-applicative
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/optparse-applicative')
-rw-r--r--dev-haskell/optparse-applicative/Manifest4
-rw-r--r--dev-haskell/optparse-applicative/metadata.xml62
-rw-r--r--dev-haskell/optparse-applicative/optparse-applicative-0.18.1.0.ebuild36
3 files changed, 40 insertions, 62 deletions
diff --git a/dev-haskell/optparse-applicative/Manifest b/dev-haskell/optparse-applicative/Manifest
index 40db1db5916c..8a34cffa8074 100644
--- a/dev-haskell/optparse-applicative/Manifest
+++ b/dev-haskell/optparse-applicative/Manifest
@@ -1,4 +1,6 @@
DIST optparse-applicative-0.16.1.0.cabal 4982 BLAKE2B 7e9fed3ff6f09f8b7994d4fd2177ade79e62bc2292dd5fa78bfdf15b0b6f7af0bd696d61ef02ed358460a61f0e2f960d01455091168687f6d2db0b07caf182f6 SHA512 31a1e01b4d0a247c10b1eec2f5bb40e518b447527736b8692846980d182ef2ac4d839b4a24b3d17414fac28700d43d0317deb481c1e0c7ac2b7b38aaafc654a1
DIST optparse-applicative-0.16.1.0.tar.gz 58315 BLAKE2B 3998ef8594abd3f0f1e85cc44a3efa19d78751f5d17181e1b203504221c219ebf3fa36ccde7351e5821fe1c4a4c0c16a20fffe92259710dbcc7656f4e3a83c50 SHA512 46bdb37b1328a6dbf271dcdb3483266c0c8412fc489e68e32b114745d9cf0108dd49df6cb565df3470121931a769f11996f5fd9fd8e9e38ed6b6853faab56710
+DIST optparse-applicative-0.18.1.0.tar.gz 60682 BLAKE2B 7fc64b6d135fbec6165050e059235a34b0cbe0633076acc97f645af9e25d805ddd5bc03101823ac4645bf7c390dd6c19d96505aeb6c54a4253317b6cbc160d8a SHA512 a5a7667cadd3c2785d787cb6bddb009750308376c771f45d72e2245577f42c2946a069bf420d3404653f9f3662cb798341ee96d1ead35dbf95ab42447698e41d
EBUILD optparse-applicative-0.16.1.0.ebuild 1230 BLAKE2B 10f977905f14f1074b0ca8051d496f08a806c3ccd4a92227a07794a6b87897d6a7a957f24f6c15cfcc3cdb55e596a21c305b86a93e331240a9c7fe277d2ad56f SHA512 88ca6348db881ee122e1109f418eb7ca73d556e7e3d6105d9f1adcf1f440d04bd60c0b0887ebbf9afaf0059d5594c7b60e418c1a9a5ee517d83c48e90f7cb089
-MISC metadata.xml 2420 BLAKE2B 18d53d68d037fe663e65808a60db600c8cdd7357289a5b66e5dd9ee0c476eab5b48374a09bb8d37e12be7ecbef24c513affcef60536b30708416918a14b1ccd8 SHA512 12e539b62236e27fa287f8844ac7fbfedbf6959ab9acab57df0faeacb2796a630e2d4b27fbad2dea6b6067072ce057735ab48fc520ee0b1ddf83c6b0b13d6950
+EBUILD optparse-applicative-0.18.1.0.ebuild 1050 BLAKE2B e7a3b45fad11969d0d702f427d1d0e5d79692b22e08ed532d5d04f6707b40ed579824243f239c072841f5513e70b18b77cb0f09c80c4d5efed1daf60252a4ce1 SHA512 b277da3e5bf27b901bf9266d77c91d6fbb4ecd37f79f1b6619a2e1894fd5b49e2197d735cf238dad5b0bcd6c876315b0b065fbd5b8b025eb44d2b1237ce12a90
+MISC metadata.xml 407 BLAKE2B 43db3f567abe3081887c3328df93e8c7e50782939282b581dc88cf1efcd8755fa5499f5e26846639c79dbd0ada00aa47fe2414557ff9bdc28e213eaf3c5b2885 SHA512 7c832cd4b71dcbbaf30657953dbd0aab3447624436dbb6480a47f47fa9c07105215092bf580dc1a4010311ab950c51fe8276292f9edecbc505e4ba603791cd0f
diff --git a/dev-haskell/optparse-applicative/metadata.xml b/dev-haskell/optparse-applicative/metadata.xml
index 3e2bcf92c04b..2a153711a9ce 100644
--- a/dev-haskell/optparse-applicative/metadata.xml
+++ b/dev-haskell/optparse-applicative/metadata.xml
@@ -5,68 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Here is a simple example of an applicative option parser:
-
- @
- data Sample = Sample
- &amp;#x20; &amp;#x7b; hello :: String
- &amp;#x20; , quiet :: Bool &amp;#x7d;
-
- sample :: Parser Sample
- sample = Sample
- &amp;#x20; \&lt;$\&gt; strOption
- &amp;#x20; ( long \"hello\"
- &amp;#x20; &amp; metavar \"TARGET\"
- &amp;#x20; &amp; help \"Target for the greeting\" )
- &amp;#x20; \&lt;*\&gt; switch
- &amp;#x20; ( long \"quiet\"
- &amp;#x20; &amp; help \"Whether to be quiet\" )
- @
-
- The parser is built using applicative style starting from a set of basic
- combinators. In this example, @hello@ is defined as an 'option' with a
- @String@ argument, while @quiet@ is a boolean 'flag' (called 'switch').
-
- A parser can be used like this:
-
- @
- greet :: Sample -&gt; IO ()
- greet (Sample h False) = putStrLn $ \"Hello, \" ++ h
- greet _ = return ()
-
- main :: IO ()
- main = execParser opts \&gt;\&gt;= greet
- &amp;#x20; where
- &amp;#x20; opts = info (helper \&lt;*\&gt; sample)
- &amp;#x20; ( fullDesc
- &amp;#x20; &amp; progDesc \"Print a greeting for TARGET\"
- &amp;#x20; &amp; header \"hello - a test for optparse-applicative\" )
- @
-
- The @greet@ function is the entry point of the program, while @opts@ is a
- complete description of the program, used when generating a help text. The
- 'helper' combinator takes any parser, and adds a @help@ option to it (which
- always fails).
-
- The @hello@ option in this example is mandatory (since it doesn't have a
- default value), so running the program without any argument will display a
- help text:
-
- &gt;hello - a test for optparse-applicative
- &gt;
- &gt;Usage: hello --hello TARGET [--quiet]
- &gt; Print a greeting for TARGET
- &gt;
- &gt;Available options:
- &gt; -h,--help Show this help text
- &gt; --hello TARGET Target for the greeting
- &gt; --quiet Whether to be quiet
-
- containing a short usage summary, and a detailed list of options with
- descriptions.
- </longdescription>
<upstream>
+ <remote-id type="hackage">optparse-applicative</remote-id>
<remote-id type="github">pcapriotti/optparse-applicative</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/optparse-applicative/optparse-applicative-0.18.1.0.ebuild b/dev-haskell/optparse-applicative/optparse-applicative-0.18.1.0.ebuild
new file mode 100644
index 000000000000..69832dbebf11
--- /dev/null
+++ b/dev-haskell/optparse-applicative/optparse-applicative-0.18.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: +process
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Utilities and combinators for parsing command line options"
+HOMEPAGE="https://github.com/pcapriotti/optparse-applicative"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/prettyprinter-1.7:=[profile?] <dev-haskell/prettyprinter-1.8:=[profile?]
+ >=dev-haskell/prettyprinter-ansi-terminal-1.1:=[profile?] <dev-haskell/prettyprinter-ansi-terminal-1.2:=[profile?]
+ >=dev-haskell/text-1.2:=[profile?]
+ >=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-0.8:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ >=dev-haskell/quickcheck-2.8 <dev-haskell/quickcheck-2.15
+ )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=process
+}