summaryrefslogtreecommitdiff
path: root/dev-haskell/text-short/text-short-0.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/text-short/text-short-0.1.3.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/text-short/text-short-0.1.3.ebuild')
-rw-r--r--dev-haskell/text-short/text-short-0.1.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-haskell/text-short/text-short-0.1.3.ebuild b/dev-haskell/text-short/text-short-0.1.3.ebuild
new file mode 100644
index 000000000000..a6f10f5a7f4d
--- /dev/null
+++ b/dev-haskell/text-short/text-short-0.1.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Memory-efficient representation of Unicode text strings"
+HOMEPAGE="https://hackage.haskell.org/package/text-short"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="asserts"
+
+RDEPEND=">=dev-haskell/hashable-1.2.6:=[profile?] <dev-haskell/hashable-1.4:=[profile?]
+ >=dev-haskell/semigroups-0.18.2:=[profile?] <dev-haskell/semigroups-0.20:=[profile?]
+ >=dev-haskell/text-1.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/quickcheck-instances-0.3.14 <dev-haskell/quickcheck-instances-0.4
+ >=dev-haskell/tasty-1.0.0 <dev-haskell/tasty-1.3
+ >=dev-haskell/tasty-hunit-0.10.0 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/tasty-quickcheck-0.10 <dev-haskell/tasty-quickcheck-0.11 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >= 4.7 && < 4.13' 'base >= 4.7' \
+ 'ghc-prim >= 0.3.1 && < 0.6' 'ghc-prim >= 0.3.1'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag asserts asserts)
+}