summaryrefslogtreecommitdiff
path: root/dev-java/jchart2d
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/jchart2d
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/jchart2d')
-rw-r--r--dev-java/jchart2d/Manifest3
-rw-r--r--dev-java/jchart2d/jchart2d-3.2.2.ebuild39
-rw-r--r--dev-java/jchart2d/metadata.xml12
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-java/jchart2d/Manifest b/dev-java/jchart2d/Manifest
new file mode 100644
index 000000000000..b93032bec311
--- /dev/null
+++ b/dev-java/jchart2d/Manifest
@@ -0,0 +1,3 @@
+DIST jchart2d-eclipse-project-3.2.2.zip 3203952 BLAKE2B 99f3058184e02b682e288675edd68c7f53f2961a1888d096c7834d011ce279b9cfc8228f801e8fc4d3b20250875c5db59cc945ab46ae62c28b85545082e684ca SHA512 aa369b78aced9f7884d51f5298a6772d00cd4003d970e0bb401b717b4bdd2fdd543cf9a382edf7c9a6d1837cedb483a04aa89aac1e66d6e365655e99c76ee812
+EBUILD jchart2d-3.2.2.ebuild 912 BLAKE2B 1d03ce8959dd57b2d714e8afec81d740054a8b113c1564e80ec37e720c5d1907a9acdb21f9f1cc168a173f42f2e83c813d1485f0ff4aea3838d29f85f606f95e SHA512 abf365afbd13a3f2ccc937ff68926ad9abf0e53deb8c96b24b3dbf0a8c361813e51d4e9b0cc95a0fa145062c36a51b412c0d037b75fcc8442df4250002e1ab49
+MISC metadata.xml 887 BLAKE2B 95100127e8f7a23358acddced99ca959b027276068f46dbb44f98fa86f0a3ea889e2bbf9b73bf369fa295b2f3e93e5c36fe34e02d526470bfaae3747569aa003 SHA512 a6e967cc43fc7e346a28b9a9be8d66e361ede6843ce7cf32c2e7bb1cb1abf147f68722d5de9e76699bdc51150f1833153b49655bc3292f81b05c1dda2d287396
diff --git a/dev-java/jchart2d/jchart2d-3.2.2.ebuild b/dev-java/jchart2d/jchart2d-3.2.2.ebuild
new file mode 100644
index 000000000000..4e3f1e632d16
--- /dev/null
+++ b/dev-java/jchart2d/jchart2d-3.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A minimalistic realtime charting library for Java"
+HOMEPAGE="http://jchart2d.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/sources/${PN}-eclipse-project-${PV}.zip"
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Even the headless tests need a display!?
+
+CDEPEND="dev-java/jide-oss:0
+ dev-java/xmlgraphics-commons:2"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}
+ app-arch/unzip"
+
+JAVA_GENTOO_CLASSPATH="jide-oss,xmlgraphics-commons-2"
+JAVA_SRC_DIR="src"
+
+S="${WORKDIR}/${PN}"
+
+java_prepare() {
+ rm -rv ext/* || die
+
+ # Ant tries and fails to build these outdated bug
+ # demonstrations. Did Ant's globbing behaviour change?
+ rm -v src/*.java || die
+}
diff --git a/dev-java/jchart2d/metadata.xml b/dev-java/jchart2d/metadata.xml
new file mode 100644
index 000000000000..306a65a8731f
--- /dev/null
+++ b/dev-java/jchart2d/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <longdescription>JChart2D is an minimalistic realtime charting library published under the OSI approved GNU LESSER GENERAL PUBLIC LICENSE. It is designed for displaying multiple traces consisting of tracepoints. JChart2D is centered around a single configureable swing widget: the Chart2D. It is a JComponent one can add to a java swing user interface. Therefore basic knowledge of java awt and swing and the information provided on this site is helpful. If no basic knowledge of swing and awt is given, the example code will give a quick entry as well.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">jchart2d</remote-id>
+ </upstream>
+</pkgmetadata>