summaryrefslogtreecommitdiff
path: root/dev-lang/php/php-8.2.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-22 23:40:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-22 23:40:36 +0000
commit1e153f5e3ce504af9cf586c9b819e4f0bc919f3b (patch)
treed6462e2ccef3a7c2e6e824e69212811a4bd727cd /dev-lang/php/php-8.2.16.ebuild
parentc794e18e3eef5414856f70733e3a62479ce78c33 (diff)
gentoo auto-resync : 22:02:2024 - 23:40:35
Diffstat (limited to 'dev-lang/php/php-8.2.16.ebuild')
-rw-r--r--dev-lang/php/php-8.2.16.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-lang/php/php-8.2.16.ebuild b/dev-lang/php/php-8.2.16.ebuild
index b577e38682dd..78da01537337 100644
--- a/dev-lang/php/php-8.2.16.ebuild
+++ b/dev-lang/php/php-8.2.16.ebuild
@@ -152,13 +152,19 @@ PATCHES=(
"${FILESDIR}/php-8.2.8-openssl-tests.patch"
)
-# ARM/Windows functions that are expected to be undefined.
+# ARM/Windows functions (bug 923335)
QA_CONFIG_IMPL_DECL_SKIP=(
__crc32d
_controlfp
_controlfp_s
)
+# Functions from alternate iconv implementations (bug 925268)
+QA_CONFIG_IMPL_DECL_SKIP+=(
+ iconv_ccs_init
+ cstoccsid
+)
+
php_install_ini() {
local phpsapi="${1}"