summaryrefslogtreecommitdiff
path: root/dev-lang/php/php-8.2.16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/php/php-8.2.16.ebuild')
-rw-r--r--dev-lang/php/php-8.2.16.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-lang/php/php-8.2.16.ebuild b/dev-lang/php/php-8.2.16.ebuild
index b577e38682dd..78da01537337 100644
--- a/dev-lang/php/php-8.2.16.ebuild
+++ b/dev-lang/php/php-8.2.16.ebuild
@@ -152,13 +152,19 @@ PATCHES=(
"${FILESDIR}/php-8.2.8-openssl-tests.patch"
)
-# ARM/Windows functions that are expected to be undefined.
+# ARM/Windows functions (bug 923335)
QA_CONFIG_IMPL_DECL_SKIP=(
__crc32d
_controlfp
_controlfp_s
)
+# Functions from alternate iconv implementations (bug 925268)
+QA_CONFIG_IMPL_DECL_SKIP+=(
+ iconv_ccs_init
+ cstoccsid
+)
+
php_install_ini() {
local phpsapi="${1}"