summaryrefslogtreecommitdiff
path: root/dev-libs/grantlee/grantlee-5.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-libs/grantlee/grantlee-5.2.0.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-libs/grantlee/grantlee-5.2.0.ebuild')
-rw-r--r--dev-libs/grantlee/grantlee-5.2.0.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-libs/grantlee/grantlee-5.2.0.ebuild b/dev-libs/grantlee/grantlee-5.2.0.ebuild
new file mode 100644
index 000000000000..5f7dff2d6d27
--- /dev/null
+++ b/dev-libs/grantlee/grantlee-5.2.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit cmake virtualx
+
+DESCRIPTION="C++ string template engine based on the Django template system"
+HOMEPAGE="https://github.com/steveire/grantlee"
+SRC_URI="http://downloads.grantlee.org/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="debug doc test"
+
+BDEPEND="
+ doc? ( app-doc/doxygen[dot] )
+ test? ( dev-qt/linguist-tools:5 )
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+RESTRICT+=" !test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.0-nonfatal-warnings.patch"
+ "${FILESDIR}/${P}-slot.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile docs
+}
+
+src_test() {
+ virtx cmake_src_test
+}
+
+src_install() {
+ use doc && local HTML_DOCS=("${BUILD_DIR}/apidox/")
+
+ cmake_src_install
+}