summaryrefslogtreecommitdiff
path: root/dev-libs/inih
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /dev-libs/inih
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'dev-libs/inih')
-rw-r--r--dev-libs/inih/Manifest3
-rw-r--r--dev-libs/inih/inih-51.ebuild42
-rw-r--r--dev-libs/inih/metadata.xml16
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/inih/Manifest b/dev-libs/inih/Manifest
new file mode 100644
index 000000000000..e483b1ed59e1
--- /dev/null
+++ b/dev-libs/inih/Manifest
@@ -0,0 +1,3 @@
+DIST inih-51.tar.gz 16258 BLAKE2B 91a5aee6e0ecadf949fbf0b58bd2596bcb985c76fc9000a671d65cb5325c51dbb8bd945ccd7721b72dafafd11c70a9c84ad910768d0fc479e5491db8b7aacbd8 SHA512 eb2f58979d93e51a09326e6c187828643887ac1a239d4b12205567c7d87a671c9c49ca99db376c031d366bc680e579c30dcea9f3eb130ec802597411b2cb3cf4
+EBUILD inih-51.ebuild 733 BLAKE2B 35c324b1927627143e78e9f18e6121e5092541ac96ff10b17fe7717f546bce6ecbd8e0f0aea086a736543f44b2fcdcc3976b3f1364f8146c39fc279b1c0bc5da SHA512 a7f9767609347bd9618156e41815b13f88551e7531f4c6ba5df58caa362d2395aea12466dc19225e2e320dc893ef17d0b48e0dc7976d36a353a46bdffb616902
+MISC metadata.xml 504 BLAKE2B 9dbb7e8ce4c8524166a60e799e67d972a60297d48aeaaa572797303f23b599168a7d9fa061550287694c0243562ab4139aa48674704e65a5ac50339bfffbb0ba SHA512 bb42c3ff3e4b1ba3b3bc70b2f1d719c3ade733d2f4c8e90d98e20d2fd716a633b22e3a4212a29c56291e7fe6c475f0e540f37454302bc279342bbec95fbd320f
diff --git a/dev-libs/inih/inih-51.ebuild b/dev-libs/inih/inih-51.ebuild
new file mode 100644
index 000000000000..3cbd85dd6604
--- /dev/null
+++ b/dev-libs/inih/inih-51.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+
+inherit meson multilib-minimal ninja-utils
+
+DESCRIPTION="inih (INI not invented here) simple .INI file parser"
+HOMEPAGE="https://github.com/benhoyt/inih"
+
+SRC_URI="https://github.com/benhoyt/inih/archive/r${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+
+DOCS=(
+ LICENSE.txt
+ README.md
+)
+
+S="${WORKDIR}/inih-r${PV}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library=shared
+ -Ddistro_install=true
+ -Dwith_INIReader=true
+ )
+
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ eninja
+}
+
+multilib_src_install() {
+ DESTDIR="${D}" eninja install
+}
diff --git a/dev-libs/inih/metadata.xml b/dev-libs/inih/metadata.xml
new file mode 100644
index 000000000000..9aa6590570ff
--- /dev/null
+++ b/dev-libs/inih/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hurikhan77+bgo@gmail.com</email>
+ <name>Kai Krakow</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/benhoyt/inih/issues</bugs-to>
+ <remote-id type="github">benhoyt/inih</remote-id>
+ </upstream>
+</pkgmetadata>