summaryrefslogtreecommitdiff
path: root/dev-ml/camomile/camomile-0.8.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/camomile/camomile-0.8.5-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/camomile/camomile-0.8.5-r1.ebuild')
-rw-r--r--dev-ml/camomile/camomile-0.8.5-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/camomile/camomile-0.8.5-r1.ebuild b/dev-ml/camomile/camomile-0.8.5-r1.ebuild
new file mode 100644
index 000000000000..68d9d15dcc3e
--- /dev/null
+++ b/dev-ml/camomile/camomile-0.8.5-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Camomile is a comprehensive Unicode library for ocaml"
+HOMEPAGE="https://github.com/yoriyuki/Camomile/wiki"
+SRC_URI="https://github.com/yoriyuki/Camomile/releases/download/rel-${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ppc x86"
+IUSE="debug +ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ dev-ml/camlp4:=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ has_version '>=dev-lang/ocaml-4.05_beta' && epatch "${FILESDIR}/ocaml405.patch"
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_compile() {
+ emake -j1 byte unidata unimaps charmap_data locale_data
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ findlib_src_install DATADIR="${D}/usr/share" BINDIR="${D}/usr/bin"
+}